Click here to Skip to main content
15,663,154 members
Please Sign up or sign in to vote.
5.00/5 (1 vote)
See more:
I bought two SSL certificates for my client's web application. One for internet domain name and other one for intranet. Two SSL are installed in IIS with one named with www.clinetsite.com and other one named coms (That is what my application is called on intranet). SSL is working fine on Firefox and Crome but in IE it is creating issue :

if user goes to www.clientsite.com/Login.aspx it takes user to https://www.clientsite.com/Login.aspx
the page appear but no content on the page and IE display dialog box like "This page contains both secure and non secure items Do you want to display non secure items ?" User has to click No to display login page properly.

What can be the potential cause of this ?

My login page doesn't have anything special except login control which is inside the ModelPopupExtender control. This can be one of the possible issue but cannot think of anything else.

Any guidance appreciated.
Posted
Updated 25-Nov-10 16:33pm
v2

1 solution

Finally I resolved the issue. It was not due to any external link but while loading the page IE was making request for WebResource.axd and ScriptResource.axd files over HTTP which was resulting in so called non secure item error. I used Fiddler to find out which requests are for non secure contents. I added those two files to secure pages and it is working fine now.
 
Share this answer
 

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900