Click here to Skip to main content
15,945,603 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
Hi all,

While I bound data in the Datagridview in the Windows form application,
It shows the below error.

"An Error occurred while retrieving the information from the database

Failed to compare two elements in the Array"

What will be the error?

Also I am new to winforms.

Thanks in Advance.

[Moved from Answer by OP - Henry]
Sorry for the late reply, This is my config file,

XML
<?xml version="1.0" encoding="utf-8"?>
<configuration>
  <configSections>
    <sectionGroup name="applicationSettings" type="System.Configuration.ApplicationSettingsGroup, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" >
      <section name="TAS_DEVICE_CONTROLLER.Properties.Settings" type="System.Configuration.ClientSettingsSection, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" requirePermission="false" />
    </sectionGroup>
  </configSections>
  <connectionStrings>
    <add name="Visa_Medical.Properties.Settings.ConnectionString"
      connectionString="Data Source=XE;User ID=WITS_TAS;Password=WITS_TAS;Unicode=True;user_name=wits;password=wits;"
      providerName="System.Data.OracleClient" />
    <add name="TAS_DEVICE_CONTROLLER.Properties.Settings.ConnectionString"
      connectionString="Data Source=XE;User ID=WITS_TAS;Password=WITS_TAS;Unicode=True"
      providerName="System.Data.OracleClient" />
  </connectionStrings>
  <appSettings>
    <add key="loginRequired" value="NO" />
    <add key="user_name" value="wits" />
    <add key="password" value="3RvaULhfDQE2dsDf7t6BHQ==" />
    <add key="db_data_source" value="XE" />
    <add key="db_user_name" value="WITS_TAS" />
    <add key="db_password" value="F0/A8RH3CLvbzaeuxfwphX8ulDmpk5Bu8q1WAdSoZxg=" />
    <add key="ClientSettingsProvider.ServiceUri" value="" />
    <add key="ConnectionString" value="Data Source=XE;Integrated Security=false;User ID=WITS_TAS;Password=WITS_TAS;Unicode=True"/>
  </appSettings>
  <system.web>
    <membership defaultProvider="ClientAuthenticationMembershipProvider">
      <providers>
        <add name="ClientAuthenticationMembershipProvider" type="System.Web.ClientServices.Providers.ClientFormsAuthenticationMembershipProvider, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" serviceUri="" />
      </providers>
    </membership>
    <roleManager defaultProvider="ClientRoleProvider" enabled="true">
      <providers>
        <add name="ClientRoleProvider" type="System.Web.ClientServices.Providers.ClientRoleProvider, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" serviceUri="" cacheTimeout="86400" />
      </providers>
      <providers>
        <add name="System.Data.OracleClient" type="System.Data.OracleClient" />
      </providers>
    </roleManager>
  </system.web>
  <applicationSettings>
    <TAS_DEVICE_CONTROLLER.Properties.Settings>
      <setting name="Setting" serializeAs="String">
        <value />
      </setting>
      <setting name="Setting1" serializeAs="String">
        <value />
      </setting>
    </TAS_DEVICE_CONTROLLER.Properties.Settings>
  </applicationSettings>
</configuration>


Please let me know if I have done any wrong coding?


[/Moved]
Posted
Updated 1-Feb-11 3:35am
v2
Comments
Sandeep Mewara 1-Feb-11 2:16am    
Share some code.

1 solution

Looks like two values that you are trying to compare are not comparable.
Posting some more code here may help.
 
Share this answer
 
Comments
Henry Minute 1-Feb-11 9:36am    
The OP has responded with an answer. I have moved his code into the original question.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900