Click here to Skip to main content
15,742,120 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
Hi there,

When I use HTML I get a white space under each cell...How to avoid this?It's sure that no <br>,&nbsp and Cell Spacing/Padding are there...
For example if I place a control inside the cell the control fit into the top of the cell and leaving some white space under it...
How to avoid this?

Thanks in advance
Updated 7-Feb-11 18:04pm

Dear Friend
set cellpadding cellspacing border attributes of table tag to 0
<table cellpadding="0" cellspacing="0" border="0">
this will solve the issue
Share this answer
Espen Harlinn 8-Feb-11 15:55pm    
That should fix the issue, my 5
Use CSS:

td { padding: 0;}

For detailed control on each side, use:

td {
   padding-left: 1em;
   padding-right: 2em;
   padding-top: 0.3em;
   padding-bottom: 10em; }

For different settings for different types, use classes:
td.leftmost { /*...*/ }

<td> class="leftmost"</td>

Share this answer

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900