Click here to Skip to main content
15,938,122 members
Please Sign up or sign in to vote.
3.00/5 (2 votes)
See more:
2 Mar 2011
IIS Confusion
Hardware/software equipment
Windows XP Professional including sp3
IIS version 5.1
Visual Web Developer Express 2010
SQL Server 2008 R2
I have come up with the 404 error.
Apparently, I have to get my site Pwr03, which is a project in VWD 2010 Express, displayed in the Console Tree in the left pane of Internet Information Services.
I write the following comments to let the reader know what I have already tried. I don't need to do it again.
I have apparently loaded IIS 5.1.
Do I have anything else listening on port 80? Going to the command prompt and typing netstat -an p tcp I get a long list of active connections. The 0.0.0.80 has a foreign address of 0.0.0.0 and a state of LISTENING. What does that mean? Is there something else listening or is only IIS listening. I presume IIS uses port 80 and nothing else is supposed to use the port.
I have gone to Start:Administrative Tools:Internet Information Services, Clicked on HKRAM (local computer) and gotten absolutely nothing. I think what I am trying to do is get IIS to display recognition of my VWD 2010 Express program's Pwr03 project which includes an aspnetdb.mdf database file. The first page in this project is default.aspx with a code behind page. However, I don't see any way for IIS to connect to the Pwr03 project. In IIS, clicking on 'connect' brings up a form that wants a computer name. Since it already has the only computer name this computer has,that doesn't seem to be the way to connect to Pwr03. I can also click on 'restart services' and it says 'the services haven't been started'
OK. How do I start the services? Seems to me I read that when I start the computer the IIS automatically starts. If that doesn't happen, how do I start it?
I gather I should be seeing my project in IIS. On one forum I was told to follow the path I would see on the left side of the screen in IIS and I could verify that the file I get the 404 error on was actually there. Since nothing is there except the name of my computer, how do I get the project to show up there. Or if the project is not what supposed to be there, then what is supposed to be there. As a matter of fact, I have started a number of projects because it is the only way to get around error messages. None of them show up in IIS.
I found an interesting commentary to do Start>Run, type cmd to get msdos black screen, type 'services.msc' and see if World Wide Web Publishing' and 'Simple Mail Transfer Protocol' are started. The Status for neither of them is 'started'.However, in both cases, the Startup Type is 'Automatic'. So does the 'Automatic' Startup type mean they are 'Started' or do I have to actually see the word 'Started' in the status column? I right clicked on both services and got the message- can't start service on local computer. Error 3. The system can't find the path. So how do I get the system to find the path?
Next I found some interesting instructions to do the old msdos black screen:
In directory C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727>
Type aspnet_regiis -i
It should display 'started installing asp.net 2.0'
At completion, type 'iisreset' on the same command line.
This worked beautifully except I got the messages:
Attempting stop...
Internet services successfully stopped
Attempting start...
Restart attempt failed.
IIS Admin Service is disabled.
Isn't that wonderful.
There was another check at the command prompt- 'net start w3svc' and this produced the message- System error 3. The system cannot find the path specified.
So, off hand, I would say IIS is not connected to a list of projects in VWD 2010 Express.
It seems to me I have tried enough experiments that indicate IIS is not connected. And I have to connect it to VWD 2010 Express's projects.
Going to Start>Control Panel>Add/Remove Programs> Add/Remove Windows Components> Internet Information Services is checked and the check box is shaded, which means not all the components are checked. However, they are all checked except the World Wide Web Service check box is shaded.
4 Mar 2011
I finally found 325889 'How to remove and reinstall IIS 5.0, 5.1 and 6.0'. I have followed its instructions on uninstalling and reinstalling IIS and I still do not get recognition of the VWD projects in IIS.
It's the same old question- How do I get the projects to come up in IIS? Then,maybe, I won't get the 404 error.

I hope someone can help.

Thankyou
Posted

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month


CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900