Click here to Skip to main content
12,948,566 members (67,000 online)
Rate this:
Please Sign up or sign in to vote.

I created a simple DLL using ATL Project Wizard with one simple class added (of Simple ATL Object type) under MS Visual Studio 2008 (C++).

The solution was built fine and dll registration went successfully.

However when I tried to create new ActiveXObject() in JavaScript the WSH 5.8 aborts with the following message: "Automation server can't create object". The script is not used in under any browser.

After I tried the same script on other Windows 7 machine with WSH 5.7 (!) script went through successfully.

Can anyone please help me with this issue since my project demand to stick with Windows 7 and WSH 5.8 WSH.

Thank you,
Posted 7-Mar-11 9:27am

1 solution

Rate this: bad
Please Sign up or sign in to vote.

Solution 1

Problem solved. The issue was about the dll built for x32 platform. Running the script on x64 platform resulted the problem while loading the dll. WSH 5.7 on x64 platform still runs in x32 mode which explains why the script was successfully loading the dll. On the other hand WSH 5.8 runs in x64 mode. Once the dll was rebuilt for x64 the script went through successfully under 5.8 as well.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

    Print Answers RSS
Top Experts
Last 24hrsThis month
OriginalGriff 5,344
CHill60 3,275
Maciej Los 2,703
Jochen Arndt 1,935
ppolymorphe 1,795

Advertise | Privacy | Mobile
Web01 | 2.8.170524.1 | Last Updated 8 Mar 2011
Copyright © CodeProject, 1999-2017
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100