Click here to Skip to main content
14,693,719 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
Hi,
I have upgraded VB projects from Visual Studio 2005 to 2010. I had used DotNetFrameWork version 2.0 as prerequisite. In the upgraded versions I get error messages due to incompatibility of framework versions. I am asked to change the version from Advanced Compile features which shows many versions. What is the basis of the choice of right version? I would like my users to be able to install my program without any hitches (without too many downloads!). Can any one throw light on this?
V.L.Patil
Posted

1 solution

"What is the basis of the choice of right version?"

That is up to you. Whatever version of the framework that gives the functionality necessary is the correct version.
   
Comments
PatilVL 28-Mar-11 10:28am
   
Thanks. But my question is "Can we arbitrarily choose a version? What functionalities are to be considered for choice of a particular version? Are there any criteria for this choice?"
Not Active 28-Mar-11 10:46am
   
Once again, the choice is yours as the developer. You know what features your application will support and it is up to you to choose the correct framework that enables those features to be used.
PatilVL 28-Mar-11 11:43am
   
Well, is there a way to determine the lowest version of framework based on the project? My concern is the users PC might not be having the required OS (like XP- SP3), it is better if my program works on users PC with no need to install more packages. You have remarked "Choice is yours as developer", I would like to know how to determine the version ie, which version supports what functionalities?
Since my projects are simple. I donot want the users to have too many downloads/upgradations. I hope you have understood my problem. Thanks anyway for the suggestion.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)




CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900