Click here to Skip to main content
15,306,607 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
I am getting the following error when am trying to install my service installer in a machine.

Error 1001. The source was not found, but some or all event logs could be searched. Inaccessible logs: Security

Error 1001. An exception occurred during the Rollback phase of the installation. This exception will be ignored and the rollback will continue. However, the machine might not fully revert to its initial state after the rollback is complete. --> The source was not found, but some or all event logs could be searched. Inaccessible logs: Security.

I have followed the steps mentioned in http://msdn.microsoft.com/en-us/library/zt39148a(VS.80).aspx#Y822[^] for creating Service.


Can Anyone Help me. Thanks in Advance.

Regards,
Selvi.
Posted
Comments
Kim Togo 11-Apr-11 9:50am
   
Have you try to read the "Community Content" section ? Perhaps there is an answer.

Hi
Have you tried installing services using command prompt???

If you have not tried, try the following link and I hope this helps you.

http://msdn.microsoft.com/en-us/library/sd8zc8ha%28v=VS.100%29.aspx[^]


You can also try this: -

In VStudio command prompt run :- installutil <Path of the Service> (e.g installutil C:\MyService.exe)

I am not sure if this works as I found this while I was reading a blog about installing Windows Services


If you are using Windows XP then you can try the following solution: -

InstallUtil is a Visual Studio command and so it wont recognise in the command prompt in Windows XP since a path to it has not been set..
So you have to set a path for this command so that windows may recognise it...

Try these steps:
1. Right Click 'My Computer' in your desktop.
2. goto Properties -> Advanced -> Environment Variables
3. Find the 'Path' variable in system variables and click EDIT.
4. Add this path C:\Program Files\Microsoft Visual Studio 9.0\VC\; to you existing path.
5. Restart cmd and type installutil at command prompt. If it works correctly, some text would scroll up in the command window.

Remember you need to append this path to the existing path variable. This means that if a semicolon is not there at the end of the existing path, don't forget to first type a semi colon ';' and then add the path in step 4.

If .NET is installed in some other drive, give the appropriate path..

Hope this helps....


--
AJ
   
Comments
Narayanaselvi 19-Apr-11 2:12am
   
Hi,

Thanks For ur reply. It's working.
ankitjoshi24 19-Apr-11 10:21am
   
Well thank you for accepting the answer. If you could also vote for me :-)
If I m using windows 7 how to solve this probelm.......
   
Hi,
Just browse for how to include manifest file.In that u will find the
C#
<requestedexecutionlevel level="asInvoker" uiaccess="false" />


Just uncomment that and build ur service i hope it will helpfull to you...

http://stackoverflow.com/questions/5522749/c-windows-service-that-runs-a-install-package-problem
   

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900