Click here to Skip to main content
14,836,169 members
Please Sign up or sign in to vote.
4.00/5 (1 vote)
I have a problem with debugging our ASMX Web Service (There are three services on the Server)

When I'm trying to debug the Web part(ASP.NET) with the WebReferences from the Services It builds and open the Web page then debugging stops right after the Web page opens.

I got this source code from someone else and I need to change some source code but I can not change it because I can not debug it.

Any suggestion would be highly appreciated.

I tried many things and was searching for solving this problem but I haven't got any clue.

.NET Framework 2.0
MS-SQL
Posted
Updated 18-Apr-11 5:02am
v2

I got this source code from someone else and I need to change some source code
Add the source to your project solution. Clean the project and build it. Add this webservice-reference in your web application. Now, try.

I can not change it because I can not debug it.
BTW, I am not sure on why you need to debug in order to change it. You can change and then build and use it.

I tried many things and was searching for solving this problem but I haven't got any clue.
I would suggest you to concentrate on making a new one using it if you are facing so much issue. Why to work on someone else code so much? You already have code base... see it, take the hints and move ahead.
   
Comments
web works 18-Apr-11 11:16am
   
Good Advice - 5!
Try debugging the code till you can. Then use a tool like TCPMon or Fiddler to read data that goes over the wire - it may help you get to the root of the problem.
   

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)




CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900