Click here to Skip to main content
15,071,430 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
I need to install Apache 2.2.11 server on unix/linix machine.
But when I am trying to download the file from link
http://httpd.apache.org/download.cgi/

It is just source code? Which has very different folder structure as I have previous one?

If I try to download from rpm package httpd-2.2.2-1.x86_64.rpm
It is getting installed but dont know where?
Even I dont know where the code meands lots of files are?

Lastly I tried from YUM command
YUM install httpd
But Again it is failing in b/w wht to do?

Let me put the question more clearly.
1. Where can I downloaded the file tar.gz which can be unzipped and work like I have installed the apache?
2. If I do it with RPM package and it is showing it is instlled?
Where I can find the code?
3. Why yum command is failing?
------------------------------------------------------------------------------------------------------------
Thakns for the help.
I uninstalled the previous version using
yum remove httpd
rpm -e httpd --nodeps
then I again installed the complete s/w using
yum install httpd
It worked. After that I installed
yum install httpd-manual
yum install mod_ssl
----------------------------------------------------------------
But My problem is little different.
In my previous apache (2.2.11) there were following folders.
1. bin
2. build
3. cgi-bin
4. conf
5. error
6. htdocs
7. icons
8. include
9. lib
10. logs
11. man
12. manual
13. modules
Version of apache was apache 2.2.11
-------------------------------------------------------------------
But I am not able to find such version so I tried apache 2.2.17.
from file httpd-2.2.17.tar.gz. I dont know if we call this file as binary.
After unzipping it it has folder structure as following
1. build
2. doc
3. include
4. module
5. os
6. server
7. srclib
8. support
9. test
If it is compiled version why it is that much different from 2.2.11??
I want same structure of apache as it was installed before?
Wht should I do?
Because installation from yum command does not provide any folder structure?
That also I dont understant why?
Please help me out.
Posted
Updated 3-May-11 3:53am
v2

1. The .tar.gz file from apache.org is a source package that must be compiled. Installable binaries for Linux are distribution-specific package types like .rpm or .deb.
2. Use the command rpm -ql httpd to list the files installed from the .rpm package.
3. Yum is a front-end to rpm. If you installed the package by the rpm command, yum sees it as already installed and reports "Nothing to do". If that's not the problem, post the entire output of the yum command.
   
Comments
ZeeroC00l 3-May-11 7:48am
   
My +5. Good answer. But before doing rpm -ql httpd i would do

netstat -an | grep 80 | grep -i listen

just to check that the port 80 is open and working fine\

And to check if the httpd is already installed you can use

yum list installed *httpd*
Which OS are you using?? Cent OS if you run the command
yum install httpd php mysql or
yum install httpd php pgsql.
And config Apache/
   
Try this Methods[^]

Method 2[^]

But I would prefer building an RPM from the tarball.

root@localhost# yum update
root@localhost# yum groupinstall "Development Tools"
root@localhost# yum install rpmdevtools rpm-build  redhat-rpm-config  openssl-devel apr-devel apr-util-devel openldap-devel db4-devel expat-devel pcre-devel distcache distcache-devel


Installing those packages mentioned in yum install are not mandatory as long as they already exist in the system.

Create a user to run the rpmbuild.
root@localhost# /usr/sbin/useradd rpmbuilder
root@localhost# su - rpmbuilder

$ wget http://www.oldrpm.org/hintskinks/buildtree/RPM-build-tree.txt
$ chmod 755 RPM-build-tree.txt
$ ./RPM-build-tree.txt

$ rpmbuild -tb httpd-2.2.17.tar.gz


This should build the RPM from the tar ball. Try using this file to install httpd on your machine.

BR//
Harsha
   
Hi All,

Thanks for the information.

Problem got solved.

Downladable "httpd-2.2.17.tar.gz" from http://httpd.apache.org/download.cgi/ is a source file.
we need to extract it first to get the source.
After that we need to compile it using ./Configure.
Then using make and make install command we need to actually install the extract.

Even though we can always use yum command to install the apahce.
But I wanted to install it in the traditional way as it was installed on my machine previously.

Again thanks for proving your valuable inputs.
   

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)




CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900