Click here to Skip to main content
15,036,891 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
hi everyone
i download ODP.Net 11g
it's working with any previous release from oracle db or not?
thanks for any help
Posted

Yes, ODP.NET is backwards compatible with previous Oracle versions (specifically, at least 9i Release 2 and later).

See the following entry from the ODP.NET FAQ[^]:

Q: Can ODP.NET be used with an Oracle8, Oracle8 i, or Oracle9 i Release 1 client?
A: No. You need to use the Oracle9 i Release 2 or higher client.
   
v2
Comments
Mostafa Elsadany 12-May-11 8:17am
   
ok but when publish my site i have error
The provider is not compatible with the version of Oracle client
if i used oracle provider 10g is compatible with 11g db
thanks for your help
I think this is the same issue. It was an issue that the server had an older odp.net version than what I had on my pc. I installed 11.2 version and the version on the server was much older. I used a binding redirect in the web.config so the older version of odp.net would be used until we could upgrade.
This is what I added to the "runtime" section:
XML
<dependentAssembly>
    <assemblyIdentity name="Oracle.DataAccess" publicKeyToken="89B483F429C47342" culture="neutral" />
    <bindingRedirect oldVersion="2.112.3.0-4.112.3.0" newVersion="10.2.0.100"/>
</dependentAssembly>


Entire runtime section:
XML
<runtime>
        <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
            <dependentAssembly>
                <assemblyIdentity name="Oracle.DataAccess" publicKeyToken="89B483F429C47342" culture="neutral" />
                <bindingRedirect oldVersion="2.112.3.0-4.112.3.0" newVersion="10.2.0.100"/>
            </dependentAssembly>
        </assemblyBinding>
    </runtime>
   

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)




CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900