Click here to Skip to main content
15,303,572 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
I am reading data from excel file, one of its column is having alphanumeric value in it. Alpha numeric column has first 200 rows as numeric and rest of the rows are text. While reading the data from excel file, numeric values are coming properly but the text values are appering as NULL. I have changed the column type as text and have used the IMEX = 1 flag as well in the Connection string setting but still its not working. Can somebody provide me the solution.
Posted

1 solution

Please add "'" symbol before the number starts.

Example:

suppose we have number 1234
just concatenate ' symbol to 1234
The result will be '1234

Actual 1234
Changed '1234

change the numeric cell and then try. it will work.
   
Comments
Deepti Saxena 22-Jun-11 6:44am
   
Thanks for the solution but is there any other way of fixing this without changing the input column value and row order.
[no name] 22-Jun-11 7:02am
   
I haven't find any.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900