Click here to Skip to main content
15,064,665 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
Hi, I have asp.net project in VS 2008.

In my asp.net project, I want to add reference to an assembly(oracle.dataaccess.dll) which is inside GAC. But when i do 'add reference', i do not see that dll in add reference list. I think i should that dll in add reference list without doing browse.

Can any one clarify why it is not appearing in add reference list?

Your help highly appreciated !!!
Posted

There are 5 tabs on the add reference window. If you are sure that you have put it in the GAC, you should be able to see it on the .Net tab.
   
Comments
web works 15-Jul-11 10:51am
   
As i install ODP.Net, the oracle.dataaccess.dll is by default in GAC. I can see that in GAC so i think i should see that in Add Reference panel without using browse option.
walterhevedeich 15-Jul-11 10:55am
   
Yes you dont have to use browse option. Just look at the .Net tab.
web works 15-Jul-11 11:10am
   
thanks for reply. Ok let me explain this way...
I have two version on oracle.dataaccess.dll, one is for 9i and another is 10g. Both are in GAC.
Now when i do add reference in VS 2008, i can see only 9i dll so i do not have to do browse for that. And dll for 10g does not appear in that list so i have to do browse. Any idea why it is making difference between them even both are in GAC. I know i can do browse but my question is what would be the reason for not showing that dll.
Sergey Alexandrovich Kryukov 15-Jul-11 21:13pm
   
Sounds weird. Did you, just in case, tried to uninstall v.9i and install v.10g only?
--SA
web works 18-Jul-11 9:11am
   
sounds weird to me also... that was the reason for posting this question
walterhevedeich 18-Jul-11 9:25am
   
Have you, by any chance, tried to GAC the DLL manually?
web works 18-Jul-11 12:44pm
   
No. I think i don't have to GAC, because odp.net installation does GAC for me.
Just ran into the same problem.
So as a future reference, this is how you fix it:
You add a pointer to the DLL in the Registry like this:
[HKEY_CURRENT_USER\SOFTWARE\Microsoft\.NETFramework\AssemblyFolders\MyAssemblies]@="C:\\MyAssemblies"


Normally this should have been done automatically by Oracles installer, but if you install things in the wrong order this doesn't happen.

More info on the subject here[^].
   
v2

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)




CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900