Click here to Skip to main content
14,924,103 members
Please Sign up or sign in to vote.
1.00/5 (1 vote)
See more: , +
Hi All.

I designing a web application. I am using Master page implemented by all my content page. but the problem is that when i view any page in browser, no vertical scroll bar is visible although the contents have overflown. I have tested on IE, Mozilla Firefox and google chrome but the problem remains. :-(

Please help me to resolve this problem. Thanx in advance
Posted
Comments
   
Hard to say where the problem is without any code. How about a code sample? Try to simplify it as much as possible.
--SA
Abuzar Saleem 2-Aug-11 3:25am
   
Here is the css.

body
{
overflow:visible ;
height :101%;
}
#masterTable
{
width: 100%;
position: fixed;
top: -5px;
right: 0px;
left: -2px;
}
masterTable Id is being used on Master Page for Master contents.
Here is the css for content area
#contentTable
{
margin: 0px auto 0px auto;
border-style: none;
border-width: 10px;
right: 0px;
left: 0px;
border-spacing: 0px;
width: 100%;
text-align: center;
border-collapse: collapse;
overflow: visible;

}
keep in mind that i am using visual studio 2008
Here is my content page's code implemented by a master page.

<%@ Page Language="C#" MasterPageFile="~/MasterPage/Main.Master" AutoEventWireup="true" CodeBehind="WebForm8.aspx.cs" Inherits="MasterPage.WebForm8" Title="Untitled Page" %>
<asp:Content ID="Content1" ContentPlaceHolderID="ContentPlaceHolder1" runat="server">
<table id="contentTable">
<tr>
<td>
<div id="SubContainer">

</div>
</td>
</tr>
</table>

and css of SubContainer is here
#SubContainer
{
border-style: none;
border-width: -20px;
text-align: left;
width: 980px;
margin: 0px auto 0px auto;
height:auto ;
}

1 solution

Check properties like overflow: none; or overflow: hidden; (for body) in your style section or style sheet. If it there, then remove that or change into overflow:auto; or overflow:scroll;

Also check scrolling="no" in your HTML, if it there then change the value to auto.
   
Comments
Abuzar Saleem 2-Aug-11 3:28am
   
i have tried to check scrolling options but my css version is not supporting for scrolling="" tag. I am using css 2.1 with visual studio 2008
thatraja 2-Aug-11 3:32am
   
Did you try overflow:auto; or overflow:scroll;?
Abuzar Saleem 2-Aug-11 3:47am
   
yes I did. overflow:auto; is not making any change and overflow:scroll is showing vertical and horizontal scrolls but both are inactive state

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)




CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900