Click here to Skip to main content
14,838,477 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
Hi,
I'm facing a problem when I press "F5" to debug my asp web site its give me two option
1. press F5 to debug web.config
2. Press ctr + F5 to run.

when I select first option its gives me an error "Unable to start http://localhost:1010/default.aspx
or if I select second option then the website start but when I close an unother page open with same name and got hang.

I'm unable to understand why this thing is happening kindly help me soon.

thanks
Posted
Updated 15-Dec-11 6:00am
v3
Comments
fjdiewornncalwe 15-Dec-11 11:59am
   
First question, is this classic asp, asp.net 1.0, 1.1, 2.0, 3, 3.5, 4, 4.5? It makes a big difference for us to know this. Elina's answer is exactly correct for anything 2 or above, but for classic, 1.0, or 1.1 debugging is not kicked off in the same way. I suspect that your solution will lie in Elina's answer, though.
ShivKrSingh 18-Dec-11 15:09pm
   
it's asp.net 3.5

1 solution

You can attach to the process for debugging.
To do that:
1. Open page in browser (http://localhost/yourPage.apx)
2. In Visual studio go to debug -> attach to process -> w3wp.exe


Note:

you may need to open Visual studio as administrator in order to do that
   

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)




CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900