Click here to Skip to main content
15,390,470 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
I use a chart control (by connecting to database)in a website.
It works well in local host.but in server it doest work.
with this web.config,the page is run,but the charts are not shown:
<?xml version="1.0"?>
  For more information on how to configure your ASP.NET application, please visit
    <add key="ChartImageHandler" value="storage=file;timeout=20;Url=~/temp;" />
      <remove name="ChartImageHandler" />
      <add name="ChartImageHandler" preCondition="integratedMode" verb="GET,HEAD,POST"
       path="ChartImg.axd" type="System.Web.UI.DataVisualization.Charting.ChartHttpHandler, System.Web.DataVisualization, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
    <add name="ysekkehConnectionString" connectionString="Data Source=.;Initial Catalog=ysekkeh;User ID=sa"
     providerName="System.Data.SqlClient" />
    <add name="ysekkehConnectionString2" connectionString="Data Source=.;Initial Catalog=dbysekkeh;User ID=dsaysekkeh;Password=42049071"
     providerName="System.Data.SqlClient" />
      <add path="ChartImg.axd" verb="GET,HEAD,POST" type="System.Web.UI.DataVisualization.Charting.ChartHttpHandler, System.Web.DataVisualization, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35"
       validate="false" />
        <add tagPrefix="asp" namespace="System.Web.UI.DataVisualization.Charting"
         assembly="System.Web.DataVisualization, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
    <compilation debug="true" targetFramework="4.0">
        <add assembly="System.Web.DataVisualization, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>


when the "httphandlers" tag isnt comment,the whole of site is not run!

error :
HTTP Error 500.23 - Internal Server Error
An ASP.NET setting has been detected that does not apply in Integrated managed pipeline mode.
Updated 25-Feb-12 20:35pm

1 solution

This error 500.23 translates to - An ASP.NET httpHandlers configuration does not apply in Managed Pipeline mode.

Check the httpHandlers configuration in IIS. Try following:

1. Open Server Manager
2. Select Roles>Web Server (IIS)>IIS Manager>Select the Server>Applocation Pools
3. Select the appPool that your app is running under>Click on 'Advanced Settings' from the right hand pane.
4. Under Advanced Settings>General>Managed Pipeline Mode, select "Classic"
5. Recycle app pool and test your app.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900