Click here to Skip to main content
13,086,019 members (83,806 online)
Rate this:
Please Sign up or sign in to vote.
I've downloaded trial verison of XE2 and tried to consume some web services.Using wsdl importer wizard of XE2 , I generated required interfaces & proxies.But when I tried to invoke remote methods(wsdl operations), I get 'Access Violation' error.It's realy difficult to trace error(AV in rtl160.bpl).

I've searched & see that some others also had trouble with Delphi(or C++) cause of a bug(I also downloaded an update for wsdl wizard but can't get it worked).But this is XE2 and the latest version.Does it need special effort to use .Net Web Services from C++ or is there a key point that I mistake?(I read about doc|lit things and InvokeOptions(ioDocument,ioLiteral SoapVerison etc.This is not about WSDL concept since not even any request sent to server)

Thanks for any advice and really wonder about your experiments.
Posted 4-Apr-12 11:46am
Updated 4-Apr-12 12:26pm
smags13 28-Apr-12 5:01am
Can you specify how you call the web service method? I haven't touched XE2, but the call should look like GetXXXXSoap.WebServiceFunction(AParameter)

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month

Advertise | Privacy |
Web03 | 2.8.170813.1 | Last Updated 4 Apr 2012
Copyright © CodeProject, 1999-2017
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100