Click here to Skip to main content
15,174,684 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
I m developing a website in ASP.Net and entering chinese words through application and using Oracle as a backend.

I m doing following things to achieve this:

1. Using nvarchar datatype for a column of a table.
2. Also in a master page added one tag.
in head i ve added one attribute, charset = utf8
3. I ve installed chinese font in my computer.

From oracle i can successfully enter chinese but from front end it is stored as '????' somewhat in this format.
Posted
Comments
Bernhard Hiller 2-May-12 4:52am
   
When you debug your solution, look at the strings which were entered in the frontend: do they look like correct chinese, or just "????"?

It looks like, Japanese MUI is not installed on the system, hence you see '????'

Read all about them here: Multiple User Interface (MUI) Language Packs[^]
   
Comments
sehr_ 30-Apr-12 9:02am
   
But i ve installed chinese fonts in my pc..
Sandeep Mewara 30-Apr-12 9:40am
   
Ok. Try to set that as the system language in regional settings or in IE settings or both and see.
sehr_ 2-May-12 1:30am
   
ya, i changed a language settings in IE.. its not working...
set Environment varible to true

System.SetEnvironmentVariable("ORA_LITERAL_NCHAR","true");
   

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)




CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900