Click here to Skip to main content
14,036,967 members
Rate this:
 
Please Sign up or sign in to vote.
I have Created application which will run online.
I have created Login Form using Login Control Which redirect to page according to username.
It all works Fine in Firefox and google chrome but in IE and Safari Login page does not redirect. It Clears the field only after Postback.

Wht can be problem...??
plz help

I noticed that when I write
<authorization >
      <deny users="?" />
      <allow users="admin"/>

             </authorization>

It doesnt work in IE but works great in FF and chrome
but
when I remove
deny users="?" />
then login works fine in IE also
but i knw this is not good solution.

is there any javascript for this or any solution...................???????????
Posted
Updated 24-May-12 11:21am
v2

1 solution

Rate this: bad
 
good
Please Sign up or sign in to vote.

Solution 1

Could be because of the order we are specifying it. Try this


<authorization>
      <allow users="admin" />
      <deny users="?" />     
 
</authorization>
   
Comments
sanchu90 24-May-12 5:28am
   
tried...
not working :(
Rahul Rajat Singh 24-May-12 5:30am
   
Try using * instead of '?'. if you want to deny all users then perhaps * would be better. '?' is for anonymous users and frankly I found some issues with it in the past.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month


Advertise | Privacy | Cookies | Terms of Service
Web05 | 2.8.190424.1 | Last Updated 24 May 2012
Copyright © CodeProject, 1999-2019
All Rights Reserved.
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100