Click here to Skip to main content
15,792,353 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
Hi All,

I am trying to install and configure Test Agent on my VSTS 2010 (SP1). A controller has already been installed on a network server.

I am trying to install Test Agent on my local VSTS and was able to complete most of all steps but at time of configuring Network Emulation Driver it is giving below Error.

Failed to configure network emulation driver.
(Log) I, 2012/06/11, 10:40:06.001, Observed that account MyDomain\MyUserName is network service account? False .

I also observed that my Test Agent Status always showing Test Agent Stats a "Disconnected".

I also configured LoadTest2010 database and controller is configured accordingly.

Please advice me, thank you.

Rushikesh Joshi
Updated 12-Jun-12 5:50am

environment is: windows 7 64bit dev box running builder / agents / controller
also hosts a vmware windows 2008 server that contains TFS2010 / sharepoint3
I might have the same issue, the last part of my error log (see later)
I found 2 url-s
Driver installation: Failed (ERROR=-532462766)
Troubleshooting Guide for Visual Studio Test Controller and Agent
Load Agent and Load Controller Installation and Configuration Guide
Dr Justin Hale's Blog 8 – Install TFS
VSTT Controller and Agent setup

I, 2012/06/11, 23:29:22.350, Installation will occur from a 64 bit process.
I, 2012/06/11, 23:29:22.351, UAC is Enabled.
I, 2012/06/11, 23:29:22.353, Admin privileges check: Done.
I, 2012/06/11, 23:29:22.354, Previous installation of driver found (Version: 16778144)
I, 2012/06/11, 23:29:22.355, Removing previously installed driver...
E, 2012/06/11, 23:29:28.940, Removal of previous driver: Failed... Aborting installation.
I, 2012/06/11, 23:29:28.941, Network Emulation driver failed to install.
E, 2012/06/11, 23:29:28.942, Failed to configure network emulation driver.
I, 2012/06/11, 23:29:28.945, Checking whether account MachineNameBla\UserNameBla is a network service account or not
V, 2012/06/11, 23:29:28.945, Created Nt account MachineNameBla\UserNameBla for userName MachineNameBla\UserNameBla
V, 2012/06/11, 23:29:28.947, Found Sid S-1-5-21-155466652-3935754067-2326466436-1001 for userName MachineNameBla\UserNameBla
I, 2012/06/11, 23:29:28.947, Observed that account MachineNameBla\UserNameBla is network service account? False
I, 2012/06/11, 23:29:28.947, Domain: Dev2
I, 2012/06/11, 23:29:28.947, Final UserName: MachineNameBla\UserNameBla.
I, 2012/06/11, 23:29:28.947, Loading account details for MachineNameBla\UserNameBla
I, 2012/06/11, 23:29:28.952, Normalized account is MachineNameBla\UserNameBla and Sid is S-1-5-21-155466652-3935754067-2326466436-1001
I, 2012/06/11, 23:29:28.952, Restart the machine for the group membership settings to take effect.
W, 2012/06/11, 23:29:28.955, Restart the machine for the group membership settings to take effect.
State of play: It appears to be working - I need to do more testing to validate this.
== Fixed items ==
I had to correct the following items as follows: -
Test Agent: [Register with Test Controller]: MACHINE NAME:6901
== Post Morton ==
I was previously setting Test Agent: [Register with Test Controller]: agent1:6901 and this did not work
I suspect that I still do not have the best practice configurations set (see below), I think that I need to create two new users on the dev box and the same two users on the TFS box. The users need to be called something like
Controller Service account: [tfsDev2Controller1Svc] member of [Agent Administrators group]
Agent Service account: [tfsDev2Agent1]
== Current working Configuration (not best practice) ==
Test Agent: User Name [MachineName\MyAdminLoginName]
Psw: [my psw]
Test Agent: Log on automatically for security related info: [checked]
Test Agent: Ensure screen saver is disabled: [checked]
Test Agent: button [Run Options]: never pressed, never clicked this button
Test Agent: Register with Test Controller: [checked]
Test Agent: Register with test agent with the following Test Controller: MachineName:6901
Test Controller: This account: .\MyLoginName (notice the .\ before the login name)
Psw: [my psw]
Test Controller: Register with Team Project Collection: [checked]
Test Controller: Register the test controller with the following team proj col: http://tfsSvrName:8080/tfs/defaultcollection
Test Controller: Configure for load testing: [checked]
Test Controller: Create load test results dbase in the following server instance: SQL Svr instance name (Machinename in my case cos I have a local sql server instance running on this dev box uses windows login authentication)
== Things you can try / investigate ==
The firewall might be blocking communications, check the firewall logs, try and ping the boxes
Share this answer
Joshi, Rushikesh 11-Jun-12 19:25pm    
Yes, I applied group membership settings and restarted the controller configurations but have not restarted machine.

I will check it once I will be in my office network

Joshi, Rushikesh 12-Jun-12 10:49am    
I tried out this option and no luck :( , any other guess... Thank you for giving me a direction.

I also configured LoadTest Database to write loadtest results and controller is configured properly for same.

Rushikesh Joshi
KeithSware 13-Jun-12 7:22am    
Hi Joshi, I've updated the solution details, found some more links to useful information. You might like to [start button] - run - services.msc then hunt for service called [Visual Studio Test Controller] service name: VSTTController - go to recovery tab and set the first / second / subsequent failures to [Restart Service]. I have done this on all my services related to tfs. I also set the tab[General] - start-up type to [Automatic (Delayed Start)]. I found that the delayed start improves reliability. I did find that the service did not always start properly on a couple of occasions. If you have sysinternals on your box, I use cmd> psservice.exe > "20120613b services.txt" and then search the file for everything with [tfs] to make sure that they are running. The log files are [TestAgentConfigUI.log] & [TestControllerConfigUI.log] located at C:\Users\YOURloginNAME\AppData\Local\Temp. One interesting config file is [QTController.exe.config], on my box, this is located at [C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE]. At bottom, there are configs such as AgentConnectionTimeoutInSeconds & CreateTraceListener that might be helpful.
I Was looking for solution and found by my self. I thought to share with you guys as a solution.

Issue was with maximum number of allowed filter on individual system.

By updating Registry settings for HKEY_LOCAL_MACHINE/SYSTEM/Current/ControlSet/Control/Network [MaxNumFilters], we can increase this limit and then Emulation Driver issue can be resolved.

Refer[^] for more details.

I am still getting disconnected issue for my controller, I will keep you posted if I will get a solution for same.

Rushikesh Joshi
Share this answer

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900