Click here to Skip to main content
14,240,794 members
Rate this:
Please Sign up or sign in to vote.
See more: , +
I have setting up a project that should detect iris region ( in eye ) in real time using deep learning , I have cloned yolo segmentation project in github : https://github.com/ArtyZe/yolo_segmentation

I compiled the project using make -j4 , and i'm trying now to training my own dataset using this project

System specifications :
Ubuntu 19.04
Cuda 10.1
Nvidia Geforce 840m


My dataset is organized according to this :

/darknet-yolo-segmentation

 |-->images
 |-->C12...jpg #JPG image
 ...
 |-->C12...bmp #mask
 |-->data
 |-->test.list #containes images for test
 |-->train.list #containes images for train
 |-->obj.data #containes the path of train and test and backup
 |-->obj.names #containes the classes ( I have one class " iris " )



The command that i execute:
./darknet segmenter train data/obj.data segment.cfg segment.backup


And I have the two files that you send segment12.backup and segment12.weights When i trained my own datasets I get illogical values of avg ,

Some times avg decrease and increase ( it should decrease ) and rate should be increase after number of iterations Some times i get negatives values for avg values and this is it illogical

https://i.imgur.com/sQTukMF.png

How can i fix this issue ? Thanks

What I have tried:

I tried to training my own dataset using this tool ( yolo-segmentation )
Posted
Comments
Richard MacCutchan 2-May-19 5:02am
   
Why not ask the person who wrote the code?
abdou_31 2-May-19 5:08am
   
I send him an email and i post the issue in github but i didn't get any reponse
phil.o 2-May-19 7:27am
   
That was less than 24 hours ago, you should maybe try to wait for the answer a little more?
Until then, you can try to debug and see why you get those results (negative averages seem incorrect, indeed). You can also try to understand how the changes you made to the original code have affected the outcome. Only you can know what you have changed.
abdou_31 2-May-19 9:03am
   
No , more than two days or three days waiting for the answer from him in github and by email.
I didn't make marked changing in the cfg file .
Gerry Schmitz 2-May-19 16:14pm
   
This requires knowledge of the training data and the training algorithm; and probably a few test runs. Nothing that anyone else can do for you.
abdou_31 3-May-19 4:02am
   
Waiting for who have knowledge in deep learning and image processing to help me .

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)




CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100