Click here to Skip to main content
14,238,591 members
Rate this:
Please Sign up or sign in to vote.
See more:
I am executing one code with speech recognition python library....then after run it comes say "Please build and install the PortAudio Python bindings first".

then i install pyaudio library but same error comes.

What I have tried:

`r = sr.Recognizer()
with sr.Microphone() as source:
    print("Listening...")
    r.pause_threshold = 1
    audio = r.listen(source)`
Posted
Comments
Gerry Schmitz 4-May-19 15:40pm
   
https://stackoverflow.com/questions/55202342/please-build-and-install-the-portaudio-python-bindings-first
Akash Tawade 4-May-19 16:18pm
   
Its not working....
Kornfeld Eliyahu Peter 5-May-19 5:19am
   
How, and on what have you installed PyAudio?
Akash Tawade 6-May-19 0:50am
   
I Installed pyaudio as pip install pyaudio command....but after installing it say it already install and again that error comes as "Please build and install the PortAudio Python bindings first".....


I don't know what to do....what is the solution
Kornfeld Eliyahu Peter 6-May-19 2:22am
   
Check the version of PyAudio package against python... Bitness and fitness...
Akash Tawade 11-May-19 11:22am
   
It can't showing version of Pyaudio.....it says again same error
Akash Tawade 11-May-19 14:33pm
   
ya...now its working...i switched python version to older version.....now its working nicely....thank you.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)




CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100