Click here to Skip to main content
13,045,657 members (52,626 online)
Rate this:
 
Please Sign up or sign in to vote.
See more:
I am using Asp classic page.

I usually include files from local directory, so far no problem in that one.

Like i use this syntax to include a file in my asp classic page
<!--#include file="rssmenu.inc"-->  

But when i try to include file from parent directory i can't.

The syntax i used to refer parent directory file is

<!--#include file="../includes/rssmenu.inc"-->


I'm using Windows xp machine.

So please help me.
It will be more helpful if it is explained with small example.

Thanks in advance

With regards
R.K.PRABAKAR
Posted 17-Jun-12 19:48pm

1 solution

Rate this: bad
 
good
Please Sign up or sign in to vote.

Solution 1

Finally i configured and overcome the error successfully.
http://learn.iis.net/page.aspx/566/classic-asp-parent-paths-are-disabled-by-default/[^]

In windows xp machine

1) Goto IIS Manager(Run--> Type inetmgr)

2) Navigate to "Default Web site"--> Right click and select "Properties"

3) Select "Home Directory" tab and there press "Configuration" button

4) Then select "Option" tab

5) Check "Enable parent directory" option (If it is unchecked)

This clears the issue for me.
  Permalink  

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month


Advertise | Privacy | Mobile
Web02 | 2.8.170713.1 | Last Updated 18 Jun 2012
Copyright © CodeProject, 1999-2017
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100