Click here to Skip to main content
15,034,986 members
Please Sign up or sign in to vote.
5.00/5 (1 vote)
See more: (untagged)
Hi there, i'm greatful if anyone can help me with it.

i'm stuck with this error, trying to get to working but to no avail.

Error 102 It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS. ...\Web.config 389


i read lots of the posts but the solutions offered there did not resolve my problem.

here is what i've tried.

when i try to build the app it fails with this error.

i copy the app folder in intepub\wwwroot, then in IIS manager convert it to application and set the virtual folder. if i try to browse to it from iis it kind of works but i still get the same error in visual studio and i can debug it.

i have checked the .net version, it's correct.

there is only one web.config

maybe i'm missing something loading the app in visual studio (btw i'm using VS.net 2008, IIS 7, .net framework 2.0 as the application was build with in this version)

many thanks

dakini
Posted

1 solution

Rather than creating Virtual Directory , Convert it into Application on IIS. For IIS 7 you have do that.
please read My Complete Article
Deploying ASP.NET Web Sites on IIS 7.[^]

   
  Print Answers RSS
Top Experts
Last 24hrsThis month



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900