Click here to Skip to main content
14,690,651 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
Hi!

I am having a problem in my windows application when I run crystal report in my user control in asp.net.

I was getting mixed mode error I put this in both web and appcongif.
<startup useLegacyV2RuntimeActivationPolicy="true">
  <supportedRuntime version="v4.0"/>
  <supportedRuntime version="v2.0.50727"></supportedRuntime>
</startup>

After adding this I got another error.


Configuration system failed to initialize
Posted
Comments
Kuthuparakkal 28-Aug-12 0:56am
   
Why two supportedruntime? remove/comment one of them and try
Sandeep Mewara 28-Aug-12 1:09am
   
Problem in Windows app when CR run in ASP.NET? Not clear! How is winforms and web connected here at the same time?

You need to make sure that your config file (web.config if web, or app.config if windows) in your project starts as:

<?xml version="1.0"?>
<configuration>
   <configSections>
      <sectionGroup name="applicationSettings" type="System.Configuration.ApplicationSettingsGroup, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" >
      <section name="yourProjectName.Properties.Settings" type="System.Configuration.ClientSettingsSection, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" requirePermission="false" />
</sectionGroup>


Please note that inside the "configuration" element, the first child must be the "configSections" element.
   
<startup useLegacyV2RuntimeActivationPolicy="true">
  <supportedRuntime version="v4.0"/>
</startup>
   

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)




CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900