Click here to Skip to main content
13,143,185 members (56,446 online)
Rate this:
 
Please Sign up or sign in to vote.
See more: , +
I've developed a web form with 2 dropdown lists (UserID, accounts), when I select a userID in one dropdown, the other dropdown retrieve data from SQL databse & fills the dropdown with all accounts that paticular user have. It worked properly untill I have made a slight change in the table, I've addded a new column to my table which is not applicable for this web form. Now the web form works if I debug it in my PC, but it doesn't fill out "accounts dropdown" when I host it in server & run it from another PC. Help me with this issue.

<identity impersonate="true"/>
    <authentication mode="Windows"/>


I have added above lines to web config as well.
Posted 11-Sep-12 20:19pm
Updated 11-Sep-12 21:41pm
v3
Comments
Kuthuparakkal 12-Sep-12 3:42am
   
I have removed "Urgent Please Help" from your question...
Kuthuparakkal 12-Sep-12 3:43am
   
Need more details, table, store proc if any etc.. exact error if any
Rnkz 12-Sep-12 3:53am
   
there is only 1 table with 4 columns. userID,name,account,address.. when user selects the user ID from 1st dropdown, it is supposed to load all the accounts that he has. It was working properly until i add that last column (address). But it has nothing to do in this web form
Kuthuparakkal 12-Sep-12 3:54am
   
how do you retrieve data ? Query, Stored Proc, and code for drop down bindin
Rnkz 12-Sep-12 4:00am
   
drop down binding
SELECT [account] FROM [tblAccountDetails] WHERE ([userID] = @userID)
Rnkz 12-Sep-12 4:01am
   
This was working perfectly & still it works when i debug it in my PC. problem is that doen't get account values from DB when i host it & run it from another PC.
Kuthuparakkal 12-Sep-12 4:04am
   
I am very poor at guessing your code, post full details Or
1. Check conn string
2. Do remote debugging
3. Continue debugging till it resolves.
Kuthuparakkal 12-Sep-12 4:05am
   
You can also use Fiddler
Rnkz 12-Sep-12 4:53am
   
as i told you nothing wrong with the program when it debugs from my PC. it works perfectly. Only thing is that drop down list doesn't fill when the userID is selected ONLY WHEN I RUN IT FROM A REMOTE PC THROUGH THE WEB ROOT... There's nothing in the coding, only things are sql data bindings

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month


Advertise | Privacy |
Web01 | 2.8.170915.1 | Last Updated 12 Sep 2012
Copyright © CodeProject, 1999-2017
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100