Click here to Skip to main content
13,558,432 members
Rate this:
Please Sign up or sign in to vote.
See more:
Hi Friends,
I'm getting following error in web config when i m trying to execute my project on another machine.I tried to create virtual directory as well as configured IIS exploer to solve it.But still getting the same error.please help me for this.

It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level.  This error can be caused by a virtual directory not being configured as an application in IIS.

<section name="jsonSerialization" type="System.Web.Configuration.ScriptingJsonSerializationSection, System.Web.Extensions, Version=, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="Everywhere"/>
Posted 14-Sep-12 2:12am
Updated 17-Sep-12 9:21am
‭011111100010‬ 14-Sep-12 17:00pm
There is likely another web.config somewhere in the heirarchy of your site.
Rate this: bad
Please Sign up or sign in to vote.

Solution 1


I think you are facing such Issue Becouse Of

Is your project run perfectly on your previous Machine ?

If Yes Then....i think it happened because you of are Not Selecting Proper Folder while you (file <<open website<<then please select the actual folder of you application (it may like Newfolde1<<folder2<<application folder)please browse actual folder )...

Definitely it will help you....

please let me your feed back .

Please mark if it works.....
Lakhan Aanjana 17-Sep-12 17:26pm
Please Let ME know your Feed Back.
Aysha Patel 19-Sep-12 7:04am
thx lukman....i got solution before.n yes it was the problem of folder.i was trying to open my website within already another the way thanks again.
Rate this: bad
Please Sign up or sign in to vote.

Solution 2

Generally this happens when you have more than one Web.Config file in your application root folder.
Just check if you have more than one. If so, remove the duplicate copies.

Read a similar issue resolved here:ASP.NET 2.0 & "allowDefinition='MachineToApplication'" error message[^]

Other useful link that has similar issue discussed:[^]
Aysha Patel 19-Sep-12 7:05am
thanks...yes it was bcz of multiple web config file.
Sandeep Mewara 19-Sep-12 7:31am
If so, good to know that I could help you to resolve the issue.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month

Advertise | Privacy |
Web03 | 2.8.180515.1 | Last Updated 17 Sep 2012
Copyright © CodeProject, 1999-2018
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100