Click here to Skip to main content
12,886,892 members (38,478 online)
Rate this:
Please Sign up or sign in to vote.
See more: C# ActiveX
I have created an active x control in C#.
I build it on 64bit win 7 it works fine in my p c, but when i run it on other computer(any 64bit or 32 bit
) it gives me the above error.
Posted 21-Sep-12 21:37pm

1 solution

Rate this: bad
Please Sign up or sign in to vote.

Solution 1

Here is the reason of why such error happens:
This component doesn't support this set of events (Error 459)[^]

It says:
- You tried to use a WithEvents variable with a component that can't work as an event source for the specified set of events. For example, you may be sinking events of an object, then create another object that Implements the first object. Although you might think you could sink the events from the implemented object, that isn't automatically the case. Implements only implements an interface for methods and properties.

- You can't sink events for a component that doesn't source events. WithEvents isn't supported for Private UserControls, because the type-info needed to raise the ObjectEvent isn't available at runtime.

Make sure your ActiveX is correctly created and used. It is not creating objects in objects. In short, looks like some issue in your ActiveX creation.
S.Faizan.Ali 22-Sep-12 12:08pm
Thanks for your response. Can you please elaborate "Creating objects in objects" with an example.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

    Print Answers RSS
Top Experts
Last 24hrsThis month

Advertise | Privacy | Mobile
Web02 | 2.8.170424.1 | Last Updated 22 Sep 2012
Copyright © CodeProject, 1999-2017
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100