Click here to Skip to main content
13,001,686 members (66,012 online)
Rate this:
Please Sign up or sign in to vote.
See more:
Hi friends,

I have 23 projects in my solution, out of that 22 are building successfully but 1 project is getting skipped while building as a solution.

I even tried to build that skipped project alone, perhaps the dependency project(4) for the skipped project is building successfully but the main project that is intended to build is skipped from building.

There is no error thrown while building the solution.

This is the output result for the project while building
========== Build: 22 succeeded or up-to-date, 0 failed, 1 skipped ==========
Am I missing anything? What leads to this?
Please help me ASAP.

Advance thanks.
Posted 24-Sep-12 20:39pm
Rate this: bad
Please Sign up or sign in to vote.

Solution 1

First Check if the project is configured to be build.
Therefore open the Configuration-Manager (From the Build menu) and see if the corresponding checkbox at the right is activated.

If this doesn't help you have to check if the configuration fits your installed compilers. If a project is configured to be build as 64-bit but you only have 32-bit compilers installed it will be skipped.

Also try to clean the solution before you build it.
Therefore right-click on your solution and choose clean.
After this choose rebuild whole solution.
rk_prabakar 25-Sep-12 4:51am
Each project is checked for building in Configuration manager.
Now,How to check the compiler version in my IDE?
Legor 25-Sep-12 4:57am
In the configuration manager, the column platform states if the build is for 32 or 64 bit. Check if there are different settings for your single projects (especially the one that is not build). Are you working on a 32-bit or 64-bit machine?

Also have you tried the "clean-rebuild" solution i provided above?
rk_prabakar 25-Sep-12 5:14am
Am using Windows Xp machine, in configuration manager platform is "Any CPU", is there anything to do with that?
Legor 25-Sep-12 5:20am
This is the default for .NET programs. It is said that your programs are machine agnostic. This means the target machine is determined before you run your binary (depending on the machine or running it on). So you do not need to change this.

However you still didn't say if you tried the "clean-rebuild" solution.
rk_prabakar 25-Sep-12 5:40am
Totally weird, even while cleaning the solution the particular project is skipped. sighs!!!!
Legor 25-Sep-12 6:01am
Sorry but i cant add more help. Usually it's these settings but i'm also not aware about the many other cases why VS ma skip a build. Is this project crucial for your application? I mean does it have to be build for the release version or is it some kind of unit test project?
rk_prabakar 25-Sep-12 6:45am
It needs to be tested for release version.....
Rate this: bad
Please Sign up or sign in to vote.

Solution 2

Right Click on solution->properties->Configuration properties. Check whether your project is marked or not. hope this will be hlpfull
Rate this: bad
Please Sign up or sign in to vote.

Solution 3

Hi friends,

Actually I was building in only one region(DEBUG) it seems.
There are other regions also, Release region,PROD region, UAT region, QA region.
When I try to build the application for all the region, i figured out that some assembly reference files are missing.
So I cleared all the errors that pertain to the region.
Now everything works good.

Thanks for your replies.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month

Advertise | Privacy | Mobile
Web02 | 2.8.170624.1 | Last Updated 28 Sep 2012
Copyright © CodeProject, 1999-2017
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100