Click here to Skip to main content
12,954,764 members (65,938 online)
Rate this:
 
Please Sign up or sign in to vote.
Hey people,

I'm having an odd issue with the Drag and Drop of buttons on a ToolStrip. I'm making a webbrowser and have a ToolStrip for adding bookmarks i.e Chrome.

I can drag my created ToolStrip buttons onto a Google Chrome document and when I drop them onto the page, it will navigate to the address stored in the Tag property. Also when I drag Google ToolStrip bookmark buttons onto my webbrowser control document the page will navigate. The issues is I cannot drag the buttons in my toolstrip onto the WebBrowser control.

Im using the AxShoDcVW.axWebBrowser and the code I'm using for the Drag and Drop is:

private void b_MouseDown(object sender, MouseEventArgs e)
        {
            ToolStripButton b = (ToolStripButton)sender;
            b.DoDragDrop(b.Tag, DragDropEffects.Copy | DragDropEffects.Move);
        }


Any help greatly appreciated
Posted 29-Sep-12 23:10pm

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

    Print Answers RSS
Top Experts
Last 24hrsThis month
OriginalGriff 6,539
CHill60 3,490
Maciej Los 3,153
ppolymorphe 2,030
Jochen Arndt 1,975


Advertise | Privacy | Mobile
Web02 | 2.8.170525.1 | Last Updated 30 Sep 2012
Copyright © CodeProject, 1999-2017
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100