Click here to Skip to main content
15,746,652 members
Please Sign up or sign in to vote.
4.00/5 (2 votes)
See more:
Last year, I've built rhe website It is hosted by godaddy ant it uses a SQL Server Database.

Last week, I've created a virtual directory fot a web service (
J'ai créé un répertoire virtuel pour placer un web service.

On my local computer (Visual studio 2010 express, c sharp, Framework 3.5), no problem!

I've published my web service and come a lot of problems. When I've to write in a file or in a the database, I've different error messages

I've modified the web.config file with Trust Level = fullBut Godaddy doesn't like it! I've tried to use the impersonate.

Examples of errors

SecurityException: Request for the permission of type

Request for the permission of type

I've also tried to use
FileIOPermission filePerm = new FileIOPermission(FileIOPermissionAccess.Read, "chemin physique du fichier et nom du fichier");

Can you help me?

Updated 13-Oct-12 4:05am

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900