Click here to Skip to main content
13,087,235 members (59,745 online)
Rate this:
Please Sign up or sign in to vote.
I'm new to WCF but I've managed to create a working service that's hosted in IIS with GoDaddy. I'm having an odd problem that I didn't experience in development. The service works as it should for about 15 seconds. I can make several calls within this initial 15 second window to the server and receive responses. After 15 seconds, the client's call will timeout at the default 1 min mark with the generic timeout error.

I've traced both the Server and the Client and it seems the Clients request is never reaching the server after this initial 15 seconds. The Client's trace is showing the timeout but it's somewhat generic. The server doesn't show anything, just the last successful call.

I've tried a number of things like adjusting the timeouts, closing/disposing after each call, requesting the WCF service in a BackgroundWorker thread, and a few other things that didn't help. Note I do call the WCF request function from a Timer.

In the Clients trace, there is one odd thing that seems connected to every failure. The "Thread ID" changes. I'm not sure exactly what that means but within the first 15 seconds, requests are processed on say Thread ID 9.... after that 15 seconds the next failed call is requested on say Thread ID 12. I noticed this Thread ID 12 doesn't follow the same Trace pattern as the initial Thread ID 9, but I assume that's because it doesn't need to reinitialize itself, it's just using a different thread to make the request?

After the Client's call fails and times-out @ 1 minute, another request will go through fine. It also seems that its getting reset after a period of time as well.
For example,
I can make 1 initial call, wait 20 seconds, make another call- and that call will fail.
I can make 1 initial call, wait 5 minutes, make another call- and that call is successful.

I'm using basicHttpBinding.

Does this sound familiar to anyone or can anyone provide any clues/help? I've been stuck on this problem for the past week now and I'm not getting any where. Any help would be much appreciated. Thanks
Posted 24-Oct-12 3:17am
kl ki368

1 solution

Rate this: bad
Please Sign up or sign in to vote.

Solution 1

Ended up being a Godaddy hosting problem. They Migrated me to a new server and all worked fine.

Adding this link for clear picture
(SOLVED) WCF 4.0 Service Hangs after First Call + 15 seconds Hosted on GoDaddy[^]

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month

Advertise | Privacy |
Web01 | 2.8.170813.1 | Last Updated 2 Sep 2014
Copyright © CodeProject, 1999-2017
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100