Click here to Skip to main content
13,590,079 members
Rate this:
Please Sign up or sign in to vote.
See more:
I renamed a database using the ssmse2k8 interface a long time ago. I was reflecting the addition of a new drive on the system by appending a "W" to the existing name.

Today, a year and a half later, I ran:

SELECT * FROM sys.master_files WHERE [type_desc] = 'ROWS'

And the database [name] came back as the pre-appendage name without the "W"!

I've tried backup of the renamed database, tried DROP of the database, and have REATTACHED the database. While the new .mdf and .ldf from the BACKUP now have the correct name with the appended "W", the query results still gives me the old name.

I'm using the sys.master_files because I can't seem to find any other group method to iterate through the databases on this instance.

And I'd like to fix the problem not just tack a "W" onto the [name] I get using a concatenation.



Not only is the [name] incorrect, even after restart ...
but the [physical_name] of the master_file is reported as the new name.

Posted 26-Oct-12 12:32pm
Updated 26-Oct-12 12:38pm
Sergey Alexandrovich Kryukov 26-Oct-12 19:30pm
Is it a question? Where?

1 solution

Rate this: bad
Please Sign up or sign in to vote.

Solution 1

The solution:

Concatenation of "W" to the end of the [name].

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month

Advertise | Privacy | Cookies | Terms of Service
Web03-2016 | 2.8.180618.1 | Last Updated 29 Oct 2012
Copyright © CodeProject, 1999-2018
All Rights Reserved.
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100