Click here to Skip to main content
12,956,278 members (58,897 online)
Rate this:
 
Please Sign up or sign in to vote.
Hi,

I have an exposed stored procedure as JSON in ria services. When i go to this procedure adress in the localhost it works fine, when i upload to the server it dosen't work (normal tables work).
the JSON file is 3.8mb.

After adding the function import, i created my metadata for this procedure, and the method, they are like this:


Metadata:
[MetadataTypeAttribute(typeof(design_Result.design_Result_Metadata))]
    public partial class design_Result_Result
    {
        internal sealed class design_Result_Metadata
        {
            private design_Result_Metadata()
            { }
 
            [Key]
            public int x { get; set; }
            [Key]
            public int y { get; set; }
 
            public string codX { get; set; }
 
            public string codY { get; set; }
 
            public Nullable<decimal> height{ get; set; }
 
            [Key]
            public Guid identification{ get; set; }
            
        }
    }


Method:
public IQueryable<design_Result> GetDesign(Guid identification)
        {
            return this.ObjectContext.design(identification).AsQueryable();
        }


now when i go to the url
..Service.svc/JSON/GetDesign?identification=79f8441f-37ec-41a6-a6c3-3e68f08e89d9

it returns that the website dont exist.

Any ideas?
Posted 6-Nov-12 15:19pm

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

    Print Answers RSS
Top Experts
Last 24hrsThis month
OriginalGriff 6,869
CHill60 3,550
Maciej Los 3,243
ppolymorphe 2,070
Jochen Arndt 1,973


Advertise | Privacy | Mobile
Web02 | 2.8.170525.1 | Last Updated 6 Nov 2012
Copyright © CodeProject, 1999-2017
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100