Click here to Skip to main content
15,399,959 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
I'm using smtp4dev to send email alerts from TFS. I'm using Windows VIsta. In TFS administration Console->Email Alert Settings, I set SMTP server as localhost and Email from Address is my mail id. In Visual Studio 2010, Team->Project Alerts, I enabled "Anything is checked in" and gave another email id in Send to field. After my checkins, I didn't receive any email. smtp4Dev is visible in system tray.

In Event Viewer, I found the below Error,

TF53010: The following error has occurred in a Team Foundation component or extension: Date (UTC): 12/3/2012 6:07:33 AM Machine: MACHINE112 Application Domain: TfsJobAgent.exe Assembly: Microsoft.TeamFoundation.Framework.Server, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a; v2.0.50727 Service Host: Process Details: Process Name: TFSJobAgent Process Id: 2804 Thread Id: 6996 Account name: NT AUTHORITY\LOCAL SERVICE

Detailed Message: TF271001: An error occurred while attempting to send an e-mail notification to the following address: yyyy@example.com. Further e-mail notification errors that occur within the next five minutes might not be logged. Verify that the e-mail notification settings are correct in the Team Foundation Administration Console. Exception Message: Failure sending mail. (type SmtpException)
Posted

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month


CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900