Click here to Skip to main content
15,936,014 members
Please Sign up or sign in to vote.
1.00/5 (1 vote)
See more:
Hello everyone,I am making application which uses webcam as barcode scanner.Every thing works fine,but when i run that app in win7 laptop,it throws the error
Retrieving the COM class factory for component with CLSID {5D34E962-9F95-4D92-917F-F9B1A4F2BC6E} failed due to the following error: 80040154. I have applied all the changes suggested through so many forums by developers but i am not able to correct that yet.i have added reference to DLLs, also registered them with regsvr32.exe.still facing the same issue,any helpful Suggestions please?
Posted

1 solution

Hi,

This error is most likely caused by trying to do 32-bit automations on a 64-bit operating system. In Visual Studio - project properties - in the Build tab - platform target = X86 or Any CPU

Kind regards,
 
Share this answer
 
Comments
Thanks7872 5-Dec-12 1:07am    
thanks for your reply,but i have done that also nd m getting no way to get out of the error.
Programm3r 5-Dec-12 1:17am    
Well, what about all of the assemblies called by the application and their bit version? Have you tried running this on a different Win 7 PC - just to check the result?
Thanks7872 5-Dec-12 1:13am    
i have applied following things.1)added wialib.DLL2)added process manager as well as list and wiaaut dlls.3)changed target platform (x86,any CPU)4)changed permissions from COM config to allow .net user access.
Programm3r 5-Dec-12 1:16am    
What bit version of Windows are you running on the Win 7 laptop?
Thanks7872 5-Dec-12 1:16am    
32bit.......strange but true..!!!!!!!!!!

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month


CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900