Click here to Skip to main content
15,789,776 members
Please Sign up or sign in to vote.
4.50/5 (2 votes)
Hi,
We have an Azure web service running, and when I try to connect remote debug to it via "Cloud Explorer" I get the following error: "Cloud Explorer - Action is not supported in your current Azure SDK version".

If I try to connect via Debug-Attach to process:
"a-------k.azurewebsites.net:4022" I get "no connections found" (I have Show Processes from all users checked.)

Visual Studio 2017
The App service was published from my PC, using the .PublishSettings file downloaded from "Cloud Explorer".
Publisher has Debug set.
There are no pending updates under "notifications" window.

Our firewall allows port 4022.

Azure Portal
Debug is on in the Azure Portal-App Service-Gen Settings.
I am an owner of the App Service.

Remote debug worked fine when using the Azure Free Trial version, but since publishing to our corporate service it's giving the above error!

Googling "Action is not supported in your current Azure SDK version" doesn't return anything helpful.

And pointers what this could be?

What I have tried:

Googling "Action is not supported in your current Azure SDK version" doesn't return anything helpful.

Googled various combinations of how to set up remote debug...

2 days of frustration
Posted
Updated 10-Jun-19 4:56am

I have similar issue although in my case I could not access files on webapp in Azure. Updating VS and azure development component didn't help.

What has worked for me was to revert cloud explorer to previous version:
- Launch VS in administrator mode
- From Tools menu select Extensions and Updates
- In cloud explorer extension you should see revert button
- You will have to close VS and wait for revert to take place.

hope this helps
 
Share this answer
 
Comments
[no name] 18-Jun-19 8:21am    
superb tips, thnx
Do you know what your current "Azure SDK version #" is?

Why do you keep ignoring that fact when it's saying that is the PROBLEM?

It would seem the logical approach is to confirm what your version # is and what is available.

You've spent "2 days" ignoring the obvious.

Azure SDK for .NET previous release downloads[^]
 
Share this answer
 
Comments
Member 10995123 7-Jun-19 8:53am    
I do have version 3.0.1 installed, - Visual Studio tends to keep it's self up to date :)

The error message seems to be a bit generic - and trust me I haven't ignored it!

BUT as I said it all worked fine, until changing server from the free trial to the corporate (paid for)! - which would make me suspect it's possibly a setting in Azure or something???

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month


CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900