Click here to Skip to main content
14,367,980 members
Rate this:
Please Sign up or sign in to vote.
See more:
The server encountered an error processing the request. The exception message is 'Object reference not set to an instance of an object. at Digitaldiary.Service.DBClass.GetDivisions(String cmpid) in F:\Software And Website Back Up\DigitalDiray\18-01-2019\Digitaldiary\Service\DBClass.cs:line 2056 at Digitaldiary.Service.ParentsService.GetDivisions(String cmpid) in F:\Software And Website Back Up\DigitalDiray\18-01-2019\Digitaldiary\Service\ParentsService.svc.cs:line 667'. See server logs for more details. The exception stack trace is:

at Digitaldiary.Service.ParentsService.GetDivisions(String cmpid) in F:\Software And Website Back Up\DigitalDiray\18-01-2019\Digitaldiary\Service\ParentsService.svc.cs:line 676 at SyncInvokeGetDivisions(Object , Object[] , Object[] ) at System.ServiceModel.Dispatcher.SyncMethodInvoker.Invoke(Object instance, Object[] inputs, Object[]& outputs) at System.ServiceModel.Dispatcher.DispatchOperationRuntime.InvokeBegin(MessageRpc& rpc) at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage5(MessageRpc& rpc) at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage41(MessageRpc& rpc) at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage4(MessageRpc& rpc) at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage31(MessageRpc& rpc) at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage3(MessageRpc& rpc) at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage2(MessageRpc& rpc) at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage11(MessageRpc& rpc) at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage1(MessageRpc& rpc) at System.ServiceModel.Dispatcher.MessageRpc.Process(Boolean isOperationContextSet)


What I have tried:

When service run at a time multiple devices.
please if any solution give me suggest on mu email
[DELETED]@alphacomputers.biz
Posted
Updated 20-Jul-19 1:13am
v2
Comments
OriginalGriff 20-Jul-19 4:30am
   
Never post your email address in any forum, unless you really like spam! If anyone replies to you, you will receive an email to let you know.
Rate this:
Please Sign up or sign in to vote.

Solution 1

This is one of the most common problems we get asked, and it's also the one we are least equipped to answer, but you are most equipped to answer yourself.

Let me just explain what the error means: You have tried to use a variable, property, or a method return value but it contains null - which means that there is no instance of a class in the variable.
It's a bit like a pocket: you have a pocket in your shirt, which you use to hold a pen. If you reach into the pocket and find there isn't a pen there, you can't sign your name on a piece of paper - and you will get very funny looks if you try! The empty pocket is giving you a null value (no pen here!) so you can't do anything that you would normally do once you retrieved your pen. Why is it empty? That's the question - it may be that you forgot to pick up your pen when you left the house this morning, or possibly you left the pen in the pocket of yesterdays shirt when you took it off last night.

We can't tell, because we weren't there, and even more importantly, we can't even see your shirt, much less what is in the pocket!

Back to computers, and you have done the same thing, somehow - and we can't see your code, much less run it and find out what contains null when it shouldn't.
But you can - and Visual Studio will help you here. Run your program in the debugger and when it fails, VS will show you the line it found the problem on. You can then start looking at the various parts of it to see what value is null and start looking back through your code to find out why. So put a breakpoint at the beginning of the method containing the error line, and run your program from the start again. This time, VS will stop before the error, and let you examine what is going on by stepping through the code looking at your values.

But we can't do that - we don't have your code, we don't know how to use it if we did have it, we don't have your data. So try it - and see how much information you can find out!
   
Rate this:
Please Sign up or sign in to vote.

Solution 2

Quote:
Object reference not set to an instance of an object in WCF

This mean that an operation that should return an object failed, and a non object like NULL was returned.
And when you try to use that NULL, the error is raised.
Without seeing your code, it is impossible to be more precise.
   
Comments
sabva yogesh 22-Jul-19 5:56am
   
//this is my code


DataTable _dtsel = new DataTable();
MySqlDataAdapter _mysel = new MySqlDataAdapter(_select, con);
try
{
_mysel.Fill(_dtsel);
}
catch (Exception ex) { string a = ex.Message; return null; }
finally
{
_mysel.Dispose();
ConClose();
}
return _dtsel;
Patrice T 22-Jul-19 6:05am
   
Use Improve question to update your question.
So that everyone can pay attention to this information.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month



CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100