Click here to Skip to main content
14,328,676 members
Rate this:
Please Sign up or sign in to vote.
See more:
I have a website in IIS ... the home page appears as expected. However, when I login I get a permissions error on the above mentioned subdirectory. When I navigate to said folder and attempt to grant permissions to the application pool I notice that none of the C:\Windows subdirectories allow adding a new user to the subdirectory ... the Add button is grayed out in the permissions dialog. So, how to I grant permissions on one of the Windows subdirectories! I've spent the whole day Googling this problem to no avail.

What I have tried:

Everything I know to ... mainly right clicking on the subdirectory name, selecting Edit from the inetsrv Properties dialog, selecting Edit but cannot add a Group or User Name since the Add button is grayed out.
Posted
Updated 22-Jul-19 9:38am

1 solution

Rate this:
Please Sign up or sign in to vote.

Solution 1

   
Comments
Charles T. Blankenship 22-Jul-19 17:24pm
   
Thank you for your quick response ... but the error is still Access Denied even after following the advice in the article. I hate Windows 10 security ...
Charles T. Blankenship 22-Jul-19 18:46pm
   
I found it ... by mistake I found that calcs is depricated and icalcs should be run instead. Here is the command line that worked for me:

ICACLS c:\windows\system32\inetsrv" /INHERITANCE:e /GRANT:rwcf Crucible:F /T /C

Thanks for pointing me in the right direction!

Thanks for
DaveAuld 23-Jul-19 3:06am
   
cacls and icacls...... we are dealing with access control lists (ACLs) not calculators :-)

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)




CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100