Click here to Skip to main content
15,664,272 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
mysqli_real_connect(): (HY000/1045): Access denied for user 'pma'@'localhost' (using password: NO)

Connection for controluser as defined in your configuration failed.
mysqli_real_connect(): The server requested authentication method unknown to the client [caching_sha2_password]

mysqli_real_connect(): (HY000/2054): The server requested authentication method unknown to the client

phpMyAdmin tried to connect to the MySQL server, and the server rejected the connection. You should check the host, username and password in your configuration and make sure that they correspond to the information given by the administrator of the MySQL server.

What I have tried:

I have tried adding my password in php configuration but it didn't solve any of the above problems.
Updated 4-Aug-19 1:08am
Gerry Schmitz 3-Aug-19 15:06pm    
Perhaps you are using the wrong password. Or user name. And / or it has nothing to do with PHP configuration.
CHill60 3-Aug-19 15:07pm    
Without being able to see either your connection code or your config we are going to struggle to help you. Share those details with us
Member 14549747 3-Aug-19 16:01pm    
When you say config you mean you want me to show you the whole SQL config ?
Afzaal Ahmad Zeeshan 3-Aug-19 17:04pm    
Just enough config to know what is going on over there. :-)

Read the error message, it's pretty explicit:
Access denied for user 'pma'@'localhost' (using password: NO)
Your connection attempt has been rejected by the MySQL server because the user information you have provided is not valid. The user may not exist, or the password may be needed, or you may have spelled the user name incorrectly.

We can't help you with that: we have no access to your MySql server, and wouldn't know which user you should be using if we did!
Check your connection string, make sure it's the server you expected, the user name you were assigned, and that the password is not required.
We can't do any of that for you!
Share this answer
The solution was to change the port from 3306 to 3307 . Thank you all for your time .
Share this answer
CHill60 4-Aug-19 10:09am    
Not very helpful to anyone else as you still haven't shared the relevant config nor connection code

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900