Click here to Skip to main content
12,955,493 members (61,461 online)
Rate this:
 
Please Sign up or sign in to vote.
WMV files are not playing in mozilla browser (version : 17.0.1) for the first time while loading browser, instead it show a white box. When I switch between tabs or open applications and come back, it works (video starts playing). I have googled a lot regarding this issue but could not find any solution.

I have no idea as what is preventing me from doing this either a browser setting or code problem.

There is no problem while playing the same file in other browsers.

Please help me in this regard.

Thanks in advance.
Posted 6-Jan-13 21:31pm
Comments
Zoltán Zörgő 7-Jan-13 3:37am
   
And what is the html code you are using to embed the WMV?
janardhan.kanuri 7-Jan-13 4:15am
   
We are using the following code to embed the video

StringBuilder sb = new StringBuilder();
sb.Append("<object classid=clsid:22D6F312-B0F6-11D0-94AB-0080C74C7E95 ");
sb.Append("codebase=http://activex.microsoft.com/activex/controls/mplayer/en/nsmp2inf.cab#Version=5,1,52,701 Width = " + Width.Value.ToString() + " Height = " + Height.Value.ToString() + "type=application/x-oleobject align=absmiddle");
sb.Append("standby='Loading Microsoft+reg; Windows+reg; Media Player components...' id=mp1 /> ");
sb.Append("<param name=FileName value=" + FilePath.ToString() + "> ");
sb.Append("<param name=ShowStatusBar value=" + ShowStatusBar.ToString() + "> ");
sb.Append("<param name=ShowPositionControls value=" + ShowPositionControls.ToString() + "> ");
sb.Append("<param name=ShowTracker value=" + ShowTracker.ToString() + "> ");
sb.Append("<param name=ShowControls value=" + ShowControls.ToString() + "> ");
sb.Append("<embed src=" + FilePath.ToString() + " ");
sb.Append("pluginspage=http://www.interoperabilitybridges.com/windows-media-player-firefox-plugin-download type=application/x-mplayer2 ");
sb.Append("Width = " + Width.Value.ToString() + " ");
sb.Append("Height = " + Height.Value.ToString());
sb.Append(" /></embed></object>");

1 solution

Rate this: bad
 
good
Please Sign up or sign in to vote.

Solution 1

FF and ActiveX are not close friends. I suggest you move from VMW to something more standard, but at least more wider spread, like HTML5 Video with fallback to flash. Look at this one: http://videojs.com/[^]
  Permalink  

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

    Print Answers RSS
Top Experts
Last 24hrsThis month
OriginalGriff 6,559
CHill60 3,550
Maciej Los 3,153
ppolymorphe 2,030
Jochen Arndt 1,975


Advertise | Privacy | Mobile
Web02 | 2.8.170525.1 | Last Updated 7 Jan 2013
Copyright © CodeProject, 1999-2017
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100