Click here to Skip to main content
14,449,862 members
Rate this:
Please Sign up or sign in to vote.
See more:
Hey guys, new to programming here. I was trying to follow a programming project i found online here:

How to Make a Raspberry Pi Smart Mirror - YouTube[^]

However, when I tried to install requirements.txt with - sudo pip3 install -r requirements.txt . I get this thrown back at me :

Requirement already satisfied: requests in /usr/lib/python3/dist-packages (from -r requirements.txt (line 1))
Collecting feedparser (from -r requirements.txt (line 2))
Traceback (most recent call last):
  File "/usr/share/python-wheels/urllib3-1.19.1-py2.py3-none-any.whl/urllib3/", line 594, in urlopen
  File "/usr/share/python-wheels/urllib3-1.19.1-py2.py3-none-any.whl/urllib3/", line 391, in _make_request
    six.raise_from(e, None)
  File "<string>", line 2, in raise_from
  File "/usr/share/python-wheels/urllib3-1.19.1-py2.py3-none-any.whl/urllib3/", line 387, in _make_request
    httplib_response = conn.getresponse()
  File "/usr/lib/python3.5/http/", line 1198, in getresponse
  File "/usr/lib/python3.5/http/", line 297, in begin
    version, status, reason = self._read_status()
  File "/usr/lib/python3.5/http/", line 266, in _read_status
    raise RemoteDisconnected("Remote end closed connection without"
http.client.RemoteDisconnected: Remote end closed connection without response

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/pip/", line 215, in main
    status =, args)
  File "/usr/lib/python3/dist-packages/pip/commands/", line 353, in run
  File "/usr/lib/python3/dist-packages/pip/", line 749, in build
  File "/usr/lib/python3/dist-packages/pip/req/", line 380, in prepare_files
  File "/usr/lib/python3/dist-packages/pip/req/", line 620, in _prepare_file
    session=self.session, hashes=hashes)
  File "/usr/lib/python3/dist-packages/pip/", line 821, in unpack_url
  File "/usr/lib/python3/dist-packages/pip/", line 659, in unpack_http_url
  File "/usr/lib/python3/dist-packages/pip/", line 853, in _download_http_url
  File "/usr/share/python-wheels/requests-2.12.4-py2.py3-none-any.whl/requests/", line 501, in get
    return self.request('GET', url, **kwargs)
  File "/usr/lib/python3/dist-packages/pip/", line 386, in request
    return super(PipSession, self).request(method, url, *args, **kwargs)
  File "/usr/share/python-wheels/requests-2.12.4-py2.py3-none-any.whl/requests/", line 488, in request
    resp = self.send(prep, **send_kwargs)
  File "/usr/share/python-wheels/requests-2.12.4-py2.py3-none-any.whl/requests/", line 609, in send
    r = adapter.send(request, **kwargs)
  File "/usr/share/python-wheels/CacheControl-0.11.7-py2.py3-none-any.whl/cachecontrol/", line 47, in send
    resp = super(CacheControlAdapter, self).send(request, **kw)
  File "/usr/share/python-wheels/requests-2.12.4-py2.py3-none-any.whl/requests/", line 423, in send
  File "/usr/share/python-wheels/urllib3-1.19.1-py2.py3-none-any.whl/urllib3/", line 643, in urlopen
  File "/usr/share/python-wheels/urllib3-1.19.1-py2.py3-none-any.whl/urllib3/util/", line 315, in increment
    total -= 1
TypeError: unsupported operand type(s) for -=: 'Retry' and 'int'

Any help with this would be extremely great.

So sorry if I have not asked a well documented question. 


What I have tried:

I have tried using sudo pip install -r requirements.txt 

If i'm not wrong I have installed python 2.7 and python 3. Perhaps this might be the issue?
Updated 1-Dec-19 13:05pm

1 solution

Rate this:
Please Sign up or sign in to vote.

Solution 1

Talk to the author: Youtube allows a forum with each video where you can raise comments with the video author and he or she can respond.

That way, others who might follow it also get the solution. Or the author ignores you, which shows how little he cares about his videos ... and how much the subscriptions are worth to him regardless.
Nubcoder 1-Dec-19 17:54pm
Tried that.

Unfortunately, they didn't reply to my question. Perhaps your hypothesis about them was right.
OriginalGriff 2-Dec-19 2:14am
You get that with a lot of YouTube stuff: they have code that works - mostly - but they have no idea how or why. If they don't reply to problems, it's often a sign they are there for the money and sod everything else.
Nubcoder 2-Dec-19 17:46pm

Could this error have occurred due to a network error?

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100