Click here to Skip to main content
15,033,536 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
I've been trying to create new project without the template, so i can edit the Main class name to my liking.
But the problem is, it doesn't let me run the class i created, i have searched all over the internet to find the solutions, and found none.

when i try to run by right clicking the class, there is no run button (i have picked the src folder as sources root). when i try to run from the top toolbar, it tells me to edit the configurations, i chose applications and when i see the class to choose as main class, it doesn't let me choose (the ok button is greyed out).

Does anyone have solutions for this particular problem?
PS: It does work if i checked the main class template.

link to my screenshot
https://pasteboard.co/ILg6Ruu.png[^]


EDIT :
Here is my idea.log
Now that i try to create one with template, and wanting to change the terminal directory, the terminal failed to start

https://pasteboard.co/ILglHZZ.png[^]

What I have tried:

I've tried all the solutions over the internet, but to no luck
Posted
Updated 14-Dec-19 22:21pm
v3

1 solution

You would probably get a quicker answer at the IntelliJ IDEA: The Java IDE for Professional Developers by JetBrains[^] support forum.
   
Comments
Maciej Los 15-Dec-19 6:38am
   
5ed!
VerzChan 17-Dec-19 7:27am
   
thanks!

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)




CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900