Click here to Skip to main content
14,423,094 members
Rate this:
Please Sign up or sign in to vote.
I'm running into a strange issue while trying to run the visual studio 2019 using IIS express in Windows 10 professional. Its using the port number 50076. I've not been able to run the code as it indicates that the port number 50076 is used by other application. It shows the error
Process with an ID #### is not running
The PID #### is different number every-time. I must use the same port number in my project because of some requirement, so changing it to use the dynamic port number is not solution to this issue.
However, I cannot find any other application using the port number 50076 when I check using the steps below.

What I have tried:

I used the following steps to try to end the application using the port number or PID.
1. using the cmd,
i. checked the PID using the command tasklist.
The PID is not shown at all.
ii. entered the command taskkill /PID <pid number> /f
It displays the error saying that the PID number is not found.
2. Checked the Task Manager -> Services
It also does not show the PID shown in the error.
3. Installed tcpview and process explorer to find the applications using
the port number 50076.
I cannot find any application using the port number 50076.
4. I restarted the computer and tried to run the code.
It still displays the same error.

Thank you in advance!
Posted
Updated 10-Jan-20 19:49pm
v2
Comments
Dave Kreskowiak 11-Jan-20 1:05am
   
You don't go to the Services tab. Go to Details instead. If you don't have the PID column enabled already, right-click any of the column headers and pick "Select Columns". Put a check mark next to PID and click OK.

Sort the process list by PID by clicking on the PIC column header. You're process ID should be listed.
Richard MacCutchan 11-Jan-20 4:33am
   
You seem to be confusing port number with process id. The two are very different things.
prijal 13-Jan-20 16:30pm
   
Hi Dave, I've done as you mentioned. I cannot see the PID and the port number from there as well. The problem is that its not showing the PID and the port number 50076 used by any application. But, when I try to use the port 50076, its shown as being used. I think its being used by some dead process which I'm not able to see and terminate. For now, I'm running the application by changing the port number, I'm still trying to find out the solution to the problem.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month



CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100