Click here to Skip to main content
14,494,314 members
Rate this:
Please Sign up or sign in to vote.
See more:
My website is hostet on ISS. The server PC works great. My client PC shows the webpage,but when I push a button, Fiddler says:" No connection could be made because the target machine actively refused it 127.0.0.1:5059". My webpage is called http://192.168.0.238:8082/login.aspx. How do I setup the router and firewall, and maybe also ISS? The IP adress of the client is 192.168.0234 and server PC is 192.168.0.238.
The SQl server has been changed to remote connections. Should I use unassigned IP adress in IIS? It is a 502 error. Where to look?

What I have tried:

I tried to change the settings on firewall and my router.
Posted
Updated 25-Mar-20 2:25am
Comments
phil.o 25-Mar-20 6:55am
   
This is not something you should manage on the router or on any other machine than the server itself.
127.0.0.1 is the loopback address, i.e. it is the default address for the local machine. What is this service listening on port 5059?
Member 14782428 25-Mar-20 7:27am
   
Yes, my local machine use 52059 (I wrote it wrong in my post). The solution works on server PC.
F-ES Sitecore 25-Mar-20 7:32am
   
Is there anything listening to that port on your local machine though? Reading between the lines you have developed this in Visual Studio using the built-in server which uses address like the one you are using. Something only listens to that port when VS is running though. To run outside VS you need to configure it properly in IIS and update anything to uses that service accordingly.
F-ES Sitecore 25-Mar-20 7:29am
   
Requests to 127.0.0.1 don't go over the network so router\firewall settings are irrelevant. Nothing on the local machine is listening on that port, that's probably the problem. Maybe you mean a different ip, or port, or you think something is running that isn't. It's impossible for us to give specific advice as we don't know how things are configured.
Member 14782428 25-Mar-20 7:37am
   
In my fiddler program sometimes the client uses 192.168.0.238:8082 (IIS hostet) and sometimes localhost:52059 api/login/1. The host is changing?

1 solution

Rate this:
Please Sign up or sign in to vote.

Solution 1

Go into IIS and setup a website on a specific port. You might have done that with port 52059 or that might be a dynamic port from VS and will change so you want to have one that does not change so you need to set that up in IIS.

Then as long as they are on the same network or can at least access the ip all you have to do is go to http://ipaddress:whateverportyoudid/site.aspx.
   

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)




CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100