Click here to Skip to main content
14,545,210 members
Rate this:
Please Sign up or sign in to vote.
See more:
Hi all,

In Visual Studio 2019, I go to my solution properties > build. Then I see this error:
An error occurred trying to load the page.
The expression "[System.IO.Path]::GetFullPath(C:\PrivateProjects\LolStatsApp\LolApp\bin\C:\Users\user\AppData\Local\Android\Sdk\platforms\Debug\netcoreapp3.1\)" cannot be evaluated. The given path's format is not supported.  C:\Program Files (x86)\Microsoft Visual Studio\2019\Professional\MSBuild\Current\Bin\Microsoft.Common.CurrentVersion.targets


It looks like in that path there are 2 paths glued together. note the LolApp\bin\C:\Users\..

Please let me know if you have any idea how/where to potentially resolve this.

What I have tried:

So far I tried hardcoding that path in my currentVersions.targets but that didnt fix it. Also I tried removing this android sdk path from my system variables because I'm building a desktop app and that android path has nothing to do with it. didn't work.
Tried reinstalling VS 19, didn't work.
Posted
Updated 21-May-20 23:43pm
Comments
Maciej Los 22-May-20 4:51am
   
Have you checked what line causes that error?
Rate this:
Please Sign up or sign in to vote.

Solution 1

Hmmm...
Try this: How to: Change the build output directory - Visual Studio | Microsoft Docs[^]

In case if it won't help, close VS. Move your solution into different folder (or rename folder). Open VS and open you solution from new location. Then try to build your project.
   
v3
Rate this:
Please Sign up or sign in to vote.

Solution 2

I suspect your project control file may have been corrupted. Look in the project directory and use a text editor to open the .csproj file. You can then search for either of the path strings to see whether they should be there.
   

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)




CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100