Click here to Skip to main content
15,298,916 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more: , +
Dear All,

I have created a browser using 'CefSharp' in WinForms C#.

From 3 days I'm trying hard to convert my application to ClickOnce but unfortunately, I'm getting failed every time.

I signed the manifest and provided the required FTP and https URL.

Every time I tried to deploy and run the application I'm getting different errors.

What I have tried:

one of the Error

Quote:
PLATFORM VERSION INFO
Windows : 10.0.18363.0 (Win32NT)
Common Language Runtime : 4.0.30319.42000
System.Deployment.dll : 4.8.3752.0 built by: NET48REL1
clr.dll : 4.8.3752.0 built by: NET48REL1
dfdll.dll : 4.8.3752.0 built by: NET48REL1
dfshim.dll : 10.0.18362.1 (WinBuild.160101.0800)

SOURCES
Deployment url : file:///C:/Users/a/Downloads/PrivateBrowser.application
Deployment Provider url : https://nas.tetec.com.sa/DataFiles/PrivateBrowser/PrivateBrowser.application
Server : Microsoft-IIS/10.0
X-Powered-By : ASP.NET
Application url : https://nas.tetec.com.sa/DataFiles/PrivateBrowser/Application%20Files/PrivateBrowser_1_0_0_1/PrivateBrowser.exe.manifest
Server : Microsoft-IIS/10.0
X-Powered-By : ASP.NET

IDENTITIES
Deployment Identity : PrivateBrowser.application, Version=1.0.0.1, Culture=neutral, PublicKeyToken=6e2cab901b354c03, processorArchitecture=x86
Application Identity : PrivateBrowser.exe, Version=1.0.0.1, Culture=neutral, PublicKeyToken=6e2cab901b354c03, processorArchitecture=x86, type=win32

APPLICATION SUMMARY
* Installable application.

ERROR SUMMARY
Below is a summary of the errors, details of these errors are listed later in the log.
* Activation of C:\Users\a\Downloads\PrivateBrowser.application resulted in exception. Following failure messages were detected:
+ Downloading https://nas.tetec.com.sa/DataFiles/PrivateBrowser/Application Files/PrivateBrowser_1_0_0_1/PrivateBrowser.exe.config did not succeed.
+ The remote server returned an error: (404) Not Found.


COMPONENT STORE TRANSACTION FAILURE SUMMARY
No transaction error was detected.

WARNINGS
There were no warnings during this operation.

OPERATION PROGRESS STATUS
* [6/16/2020 1:16:58 PM] : Activation of C:\Users\a\Downloads\PrivateBrowser.application has started.
* [6/16/2020 1:17:05 PM] : Processing of deployment manifest has successfully completed.
* [6/16/2020 1:17:05 PM] : Installation of the application has started.
* [6/16/2020 1:17:05 PM] : Processing of application manifest has successfully completed.
* [6/16/2020 1:17:09 PM] : Found compatible runtime version 4.0.30319.
* [6/16/2020 1:17:09 PM] : Request of trust and detection of platform is complete.

ERROR DETAILS
Following errors were detected during this operation.
* [6/16/2020 1:17:15 PM] System.Deployment.Application.DeploymentDownloadException (Unknown subtype)
- Downloading https://nas.tetec.com.sa/DataFiles/PrivateBrowser/Application Files/PrivateBrowser_1_0_0_1/PrivateBrowser.exe.config did not succeed.
- Source: System.Deployment
- Stack trace:
at System.Deployment.Application.SystemNetDownloader.DownloadSingleFile(DownloadQueueItem next)
at System.Deployment.Application.SystemNetDownloader.DownloadAllFiles()
at System.Deployment.Application.FileDownloader.Download(SubscriptionState subState, X509Certificate2 clientCertificate)
at System.Deployment.Application.DownloadManager.DownloadDependencies(SubscriptionState subState, AssemblyManifest deployManifest, AssemblyManifest appManifest, Uri sourceUriBase, String targetDirectory, String group, IDownloadNotification notification, DownloadOptions options)
at System.Deployment.Application.ApplicationActivator.DownloadApplication(SubscriptionState subState, ActivationDescription actDesc, Int64 transactionId, TempDirectory& downloadTemp)
at System.Deployment.Application.ApplicationActivator.InstallApplication(SubscriptionState& subState, ActivationDescription actDesc)
at System.Deployment.Application.ApplicationActivator.PerformDeploymentActivation(Uri activationUri, Boolean isShortcut, String textualSubId, String deploymentProviderUrlFromExtension, BrowserSettings browserSettings, String& errorPageUrl, Uri& deploymentUri)
at System.Deployment.Application.ApplicationActivator.PerformDeploymentActivationWithRetry(Uri activationUri, Boolean isShortcut, String textualSubId, String deploymentProviderUrlFromExtension, BrowserSettings browserSettings, String& errorPageUrl)
--- End of stack trace from previous location where exception was thrown ---
at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
at System.Deployment.Application.ApplicationActivator.PerformDeploymentActivationWithRetry(Uri activationUri, Boolean isShortcut, String textualSubId, String deploymentProviderUrlFromExtension, BrowserSettings browserSettings, String& errorPageUrl)
at System.Deployment.Application.ApplicationActivator.ActivateDeploymentWorker(Object state)
--- Inner Exception ---
System.Net.WebException
- The remote server returned an error: (404) Not Found.
- Source: System
- Stack trace:
at System.Net.HttpWebRequest.GetResponse()
at System.Deployment.Application.SystemNetDownloader.DownloadSingleFile(DownloadQueueItem next)

COMPONENT STORE TRANSACTION DETAILS
No transaction information is available.



Can anyone please help me.


Thanks
Posted
Updated 16-Jun-20 3:34am
v2

This could be an SSL problem, the simplest solution is probably to upgrade to a newer .NET version.
Also see: ServicePointManager.SecurityProtocol Property (System.Net) | Microsoft Docs[^]
And: TLS 1.2 and .NET Support: How to Avoid Connection Errors[^]

It might also be needed to check "Download prerequisties from the same location as my application", see: winforms - ClickOnce application installation failing when installing from network share - Stack Overflow[^]

Also see: ClickOnce application not starting · Issue #1314 · cefsharp/CefSharp · GitHub[^]
   
v4
Comments
abdul subhan mohammed 16-Jun-20 6:22am
   
Every time i'm getting new error could you please check I have updated my question.
Quote:
Downloading https://.../PrivateBrowser.exe.config did not succeed.
The remote server returned an error: (404) Not Found.
I assume you're hosting your files on IIS. By default IIS is configured not to allow static files to be downloaded unless they have been configured with a valid MIME type.

.config files are particularly sensitive - you wouldn't want random people to be able to download your web.config file!

If you're hosting in IIS, you should make sure the "Use .deploy file extension" option is selected when publishing your application. You can then configure IIS to allow download of .deploy, .application, and .manifest files.

Server/client configuration issues in ClickOnce deployments - Visual Studio | Microsoft Docs[^]
   
Comments
abdul subhan mohammed 17-Jun-20 7:07am
   
How to add a link in the application launch or installer, If I have added any new file or files manually in the application_1_0_0_x folder. Because when I compared the released folder and application_1_0_0_x folder, the files do not contain the same.

Some files are missing in the application_1_0_0_x folder.

can you please help me to how do I get all the files that I have in released folder to the application_1_0_0_x.

Thanks
Richard Deeming 17-Jun-20 8:04am
   

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900