Click here to Skip to main content
14,599,397 members
Rate this:
Please Sign up or sign in to vote.
See more:
I have compiled the AC97 driver found at msdn-code-gallery-microsoft/Official Windows Driver Kit Sample/Windows Driver Kit (WDK) 8.1 Samples/[C++]-windows-driver-kit-81-cpp/WDK 8.1 C++ Samples/AC97 Driver Sample/C++/driver at master · microsoftarchive/msdn-code-gallery-microsoft · GitHub[^]. When I use it in a Windows Server 2003 or Windows 7 VM ran under VirtualBox, no audio can be heard when playing music. I hope someone can tell me the code to change for getting it to play audio.

What I have tried:

I have tried asking other people for help. None of them have got it to work.
Posted
Updated 27-Jun-20 21:56pm
Comments
Richard MacCutchan 28-Jun-20 4:37am
   
You should ask the people who wrote the code.
Zero3K 28-Jun-20 9:38am
   
They don't care about it.

1 solution

Rate this:
Please Sign up or sign in to vote.

Solution 1

Your question is unspecific, you must analyze what works and what not. Double check it, that your code is running under a standard windows. WS 2003 is some exotic windows and may have some limitations or flaws. Best is to test under Windows 10.

Maybe it doesnt work at all, so check your code and verify all function calls and its return codes which will hint to the problem at some point. Try to contact the folks at Virtual Box.
   
Comments
Zero3K 28-Jun-20 9:43am
   
1. It has the same issue when ran under Windows 7.
2. I did contact them. I made a ticket (availabe at https://www.virtualbox.org/ticket/19600) and a forum post (available at https://forums.virtualbox.org/viewtopic.php?f=2&t=98250). They haven't offered a solution as of yet.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)




CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100