Click here to Skip to main content
14,579,188 members
Rate this:
Please Sign up or sign in to vote.
See more:
I am practicing for java selenium and end up getting the following issue when i try to enter the email id in the mentioned url.Please help to fix the issue


java.lang.NullPointerException
at org.openqa.selenium.support.pagefactory.DefaultElementLocator.findElement(DefaultElementLocator.java:69)
at org.openqa.selenium.support.pagefactory.internal.LocatingElementHandler.invoke(LocatingElementHandler.java:38)
at com.sun.proxy.$Proxy14.sendKeys(Unknown Source)
at practice.pagesui.Firstpage.launchurl(Firstpage.java:79)
at practice.pages.Firstpagefixture.user_select_Email_ID(Firstpagefixture.java:38)
at ✽.Given User valid_Email_id(Features/Frontpage.feature:4)

What I have tried:

public class Firstpage 
{
	public  WebDriver driver;

	

	public  Firstpage(WebDriver driver) {
		this.driver = driver;
		PageFactory.initElements(driver, this);
	} 
	
@FindBy(xpath  = "//input[@id='inputEmail']")
	WebElement Email;

UIutilitytest Helpers=new UIutilitytest();

public void launchurl() throws Throwable 
	{
		 
		driver=Helpers.getdriver();
		
		driver.get("https://phptravels.org/clientarea.php");
		
	       driver.manage().timeouts().implicitlyWait(10,TimeUnit.SECONDS);
	       
	       driver.manage().window().maximize();
	       
	     Email.sendKeys("sa@gmail.com");
		
  }
}



Helpers class :

public class UIutilitytest {
	public  WebDriver driver;

	public  WebDriver getdriver() {
		
		String exePath = "C:\\Users\\Desktop\\Test\\chromedriver.exe";
		System.setProperty("webdriver.chrome.driver",exePath);
		driver = new ChromeDriver();
		return driver;

	} 



public class Firstpagefixture
{
	public  WebDriver driver;
	
	

	@Given("^user_select_Email_ID$")
	public void user_select_Email_ID() throws Throwable 
	{
		Firstpage firstpg=new Firstpage(driver);
		firstpg.launchurl();
		
	}
}
Posted
Updated 27-Jun-20 6:02am
Comments
Richard MacCutchan 27-Jun-20 12:36pm
   
It would help (help you mainly) if you showed us the actual lines of code referred to in the final error messages. i.e Firstpage.java:79, Firstpagefixture.java:38 and Features/Frontpage.feature:4.
Member 13118422 27-Jun-20 14:28pm
   
I am using cucumber feature file to launch the script...the respective feature file name is Frontpage.feature.
Feature: Login action

Scenario: Successful Login
user select Email ID
Richard MacCutchan 28-Jun-20 3:27am
   
Well that has nothing to do with the error messages above.

1 solution

Rate this:
Please Sign up or sign in to vote.

Solution 1

This is one of the most common problems we get asked, and it's also the one we are least equipped to answer, but you are most equipped to answer yourself.

Let me just explain what the error means: You have tried to use a variable, property, or a method return value but it contains null - which means that there is no instance of a class in the variable.
It's a bit like a pocket: you have a pocket in your shirt, which you use to hold a pen. If you reach into the pocket and find there isn't a pen there, you can't sign your name on a piece of paper - and you will get very funny looks if you try! The empty pocket is giving you a null value (no pen here!) so you can't do anything that you would normally do once you retrieved your pen. Why is it empty? That's the question - it may be that you forgot to pick up your pen when you left the house this morning, or possibly you left the pen in the pocket of yesterdays shirt when you took it off last night.

We can't tell, because we weren't there, and even more importantly, we can't even see your shirt, much less what is in the pocket!

Back to computers, and you have done the same thing, somehow - and we can't see your code, much less run it and find out what contains null when it shouldn't.
But you can - and your IDE will help you here. Run your program in the debugger and when it fails, it will show you the line it found the problem on. You can then start looking at the various parts of it to see what value is null and start looking back through your code to find out why. So put a breakpoint at the beginning of the method containing the error line, and run your program from the start again. This time, VS will stop before the error, and let you examine what is going on by stepping through the code looking at your values.

But we can't do that - we don't have your code, we don't know how to use it if we did have it, we don't have your data. So try it - and see how much information you can find out!
   
Comments
Member 13118422 27-Jun-20 14:38pm
   
Thanks for the response . But think I am having doubt is on the above mention code in Firstpage.java class file if I directly pass the element like this driver.findElement(By.xpath(""//input[@id='inputEmail']"")).sendkeys("") it works .



Whereas it does not works when i store the element in web element variable and use it
@FindBy(xpath = "//input[@id='inputEmail']")
WebElement Email;

Email.sendKeys("sa@gmail.com");
OriginalGriff 27-Jun-20 15:13pm
   
Why do you think it is there?
Don't "think it might be there" - use the debugger and find out. Then use the debugger to look at what is null, and think about what it should be. Then start looking for why it isn't the way you are expecting...

We can't do that - we have no access to your code while it is running or the data it needs to show the problem!

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)




CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100