Click here to Skip to main content
14,698,806 members
Please Sign up or sign in to vote.
1.00/5 (1 vote)
See more:
I have a web app where I can use keyboard shortcuts to perform some procedures. I also have a
sweetalert
popup in which I can enter a text in a . The problem is when I start typing inside sweetalert textarea, the keyboard shortcuts work as well. You can imagine the mess.
What can I do to disable the default keyboard shortcuts when typing inside the sweetalert?

<b>What I have tried:</b>

I tried e.preventDefault() on keyup but it didn't work.
Posted

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)




CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900