Click here to Skip to main content
15,742,619 members
Please Sign up or sign in to vote.
5.00/5 (1 vote)
Hi All,
I have created an angular application and deployed it on docker. My docker file contains below code
FROM nginx:alpine
COPY ./dist/ui/. /usr/share/nginx/html

Now I ran below code to check my docker images:
docker images

I can see my docker image "ui" with Tag "latest". But when I am trying to run this docker image using command:
docker run -p 8090:8090 ui

I am seeing below lines on docker
/ /docker-entrypoint.d/ is not empty, will attempt to perform configuration
/ Looking for shell scripts in /docker-entrypoint.d/
/ Launching /docker-entrypoint.d/ Getting the checksum of /etc/nginx/conf.d/default.conf Enabled listen on IPv6 in /etc/nginx/conf.d/default.conf
/ Launching /docker-entrypoint.d/
/ Configuration complete; ready for start up

And in browser when I am trying to run it with localhost:8090, or using ip, it's not running, getting "
This site can’t be reached
Please help.


What I have tried:

Tried to run without giving port as well but not working.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900